OOM crash coming from nsUrlClassifier (Firefox 9+)

RESOLVED DUPLICATE of bug 702217

Status

()

Toolkit
Safe Browsing
--
critical
RESOLVED DUPLICATE of bug 702217
6 years ago
4 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-f68c40c9-ccbb-417a-bbe3-696ec2111121 .
============================================================= 

Crash Stack:
0 	mozalloc.dll 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:77
1 	mozalloc.dll 	mozalloc_handle_oom 	memory/mozalloc/mozalloc_oom.cpp:54
2 	xul.dll 	nsTArray_base<nsTArrayDefaultAllocator>::EnsureCapacity 	obj-firefox/dist/include/nsTArray-inl.h:125
3 	xul.dll 	nsTArray<unsigned int,nsTArrayDefaultAllocator>::AppendElements<unsigned int> 	obj-firefox/dist/include/nsTArray.h:830
4 	xul.dll 	nsUrlClassifierStore::ReadPrefixes 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3562
5 	xul.dll 	nsUrlClassifierDBServiceWorker::ConstructPrefixSet 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3589
6 	xul.dll 	nsUrlClassifierDBServiceWorker::ApplyUpdate 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3159
7 	xul.dll 	nsUrlClassifierDBServiceWorker::FinishUpdate 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3194
8 	xul.dll 	nsRunnableMethodImpl<unsigned int 	obj-firefox/dist/include/nsThreadUtils.h:345
9 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
10 	xul.dll 	nsThreadStartupEvent::Run 	xpcom/threads/nsThread.cpp:201
11 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
12 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
13 	msvcr80.dll 	_callthreadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:348
14 	msvcr80.dll 	_threadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:326
15 	kernel32.dll 	BaseThreadStart 	

This is topcrash #33 in Firefox 9 data from yesterday, it majorly happens in 9.0b2 builds, but I'm also seeing 10.0a2 Aurora and 11.a1 Nightly crashes with that signature in https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%28char%20const*%20const%29%20|%20mozalloc_handle_oom%28%29%20|%20nsTArray_base%3CnsTArrayDefaultAllocator%3E%3A%3AEnsureCapacity%28unsigned%20int%2C%20unsigned%20int%29%20|%20nsTArray%3Cunsigned%20int%2C%20nsTArrayDefaultAllocator%3E%3A%3AAppendElements%3Cunsigned%20int%3E%28unsigned%20int%20const*%2C%20unsign...
(Reporter)

Updated

6 years ago
tracking-firefox10: --- → ?
tracking-firefox9: --- → ?
(Reporter)

Comment 1

6 years ago
Oops, bug 702217 is already there.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
tracking-firefox10: ? → ---
tracking-firefox9: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 702217
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.