Closed Bug 704175 Opened 9 years ago Closed 8 years ago

requestAnimationFrame callback function name should be "sample", not "onBeforePaint"

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla11

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

(Keywords: addon-compat, dev-doc-needed)

Attachments

(2 files)

Blocks: 704063
https://mxr.mozilla.org/addons/search?string=onBeforePaint says we have no consumers of this in addons.  We do have some in our own tree.
Keywords: addon-compat
Keywords: dev-doc-needed
I wonder whether I should rename nsIAnimationFrameListener to nsIFrameRequestCallback in the process...
Whiteboard: [need review]
Version: 9 Branch → Trunk
Er, you need to rev the IID too.
Hmm..  I guess I do to make JS that does iid-detection work.  :(  Will do.

Thoughts on comment 2?
Is iid rev really required? Method name change is binary compatible.
"I guess I do to make JS that does iid-detection work".
(In reply to Boris Zbarsky (:bz) from comment #5)
> Thoughts on comment 2?

Seems like a good idea.
OK, I'll add a patch to rename the interface, and change its iid at the same time.
Blocks: 704171
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.