Closed Bug 704232 Opened 10 years ago Closed 10 years ago

Attempt to use JS function on a different thread calling nsIWebProgressListener.onStateChange. JS objects may not be shared across threads.

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 703656

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Crash Data

E/GeckoConsole( 4526): Attempt to use JS function on a different thread calling nsIWebProgressListener.onStateChange. JS objects may not be shared across threads.


I/ActivityManager(  110): Starting: Intent { flg=0x40000000 cmp=org.mozilla.fennec/org.mozilla.gecko.TabsTray } from pid 4597
D/PhoneWindow( 4597): couldn't save which view has focus because the focused view org.mozilla.gecko.gfx.LayerView@4050edd8 has no id.
I/GeckoApp( 4597): pause
I/WindowManager(  110): WIN DEATH: Window{4055c3d8 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
D/Zygote  (   75): Process 4597 exited cleanly (1)
I/WindowManager(  110): WIN DEATH: Window{4066f028 SurfaceView paused=false}
I/WindowManager(  110): WIN DEATH: Window{40543290 org.mozilla.fennec/org.mozilla.gecko.TabsTray paused=false}
I/ActivityManager(  110): Process org.mozilla.fennec (pid 4597) has died.


STR:

1. cnn.com (first tab), msnbc.com (second tab)
2. Switch back and forth between tabs

--
Samsung Nexus S (Android 2.3.6)
20111121040255
http://hg.mozilla.org/projects/birch/rev/41b63b2b6420
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703656
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.