Last Comment Bug 704394 - Spell checker thinks "quinoa" is a misspelling
: Spell checker thinks "quinoa" is a misspelling
Status: RESOLVED FIXED
[good first bug][mentor=ehsan]
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Sowmya R
:
Mentors:
http://pastebin.mozilla.org/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 19:34 PST by Daniel Holbert [:dholbert] (largely AFK until June 28)
Modified: 2012-03-08 14:06 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Word 'quinoa' added to dictionary (2.49 KB, patch)
2012-01-26 23:00 PST, Sowmya R
no flags Details | Diff | Review
Patch modified (2.84 KB, patch)
2012-01-28 04:32 PST, Sowmya R
ehsan: review+
Details | Diff | Review
patch (875.08 KB, patch)
2012-02-24 03:33 PST, Sowmya R
no flags Details | Diff | Review
Word 'quinoa' added (3.15 KB, patch)
2012-03-06 06:01 PST, Sowmya R
ehsan: review+
Details | Diff | Review

Description Daniel Holbert [:dholbert] (largely AFK until June 28) 2011-11-21 19:34:17 PST
STEPS TO REPRODUCE:
 1. Visit http://pastebin.mozilla.org/
 2. Type "quinoa" into the text box

ACTUAL RESULTS: Squiggly red underline (misspelling)
EXPECTED RESULTS: No squiggly red underline.

My man Merriam-Webster backs me up:
 http://www.merriam-webster.com/dictionary/quinoa
as does the original, definitive source on the English language, NinjaWords:
  http://ninjawords.com/quinoa
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-16 09:27:47 PST
I wrote up some documentation on how you can edit the en-US dictionary shipped with Firefox: <https://developer.mozilla.org/en-US/Adding_a_new_word_to_the_en-US_dictionary>.  Please let me know if you have any questions.
Comment 2 Sowmya R 2012-01-26 23:00:35 PST
Created attachment 592065 [details] [diff] [review]
Word 'quinoa' added to dictionary
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-27 09:29:10 PST
Comment on attachment 592065 [details] [diff] [review]
Word 'quinoa' added to dictionary

You should also overwrite the en-US.dic file in extensions/spellcheck/locales/en-US/hunspell with the one created in extensions/spellcheck/locales/en-US/hunspell/dictionary-sources.
Comment 4 Sowmya R 2012-01-28 04:32:48 PST
Created attachment 592389 [details] [diff] [review]
Patch modified
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-30 12:06:00 PST
Comment on attachment 592389 [details] [diff] [review]
Patch modified

This looks great!  Thanks a lot, Sowmaya!
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-30 12:08:30 PST
Hmm, wait.  There's one strange thing about the en-US.dic part of the patch.  The number at the beginning of the file should be incremented, but it's not.  Can you please update your Mercurial checkout (using hg revert -a --no-backup && hg pull -u) and rerun the steps in the document, and see if you get the number change at the beginning of en-US.dic inside the patch?  Thanks!
Comment 7 Mozilla RelEng Bot 2012-01-30 12:10:42 PST
Autoland Patchset:
	Patches: 592065, 592389
	Branch: mozilla-central => try
	Destination: ssh://hg.mozilla.org/try
Insufficient permissions to push to try
Comment 8 Sowmya R 2012-02-24 03:33:05 PST
Created attachment 600350 [details] [diff] [review]
patch

word count incremented
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2012-02-24 10:16:35 PST
Comment on attachment 600350 [details] [diff] [review]
patch

Thanks.  Looks like you forgot to run merge-dictionaries as specified here? https://developer.mozilla.org/en-US/Adding_a_new_word_to_the_en-US_dictionary  If this is done correctly, the en-US file should only have two changes, the word count increment and the introduction of quinoa.
Comment 10 Sowmya R 2012-03-06 06:01:26 PST
Created attachment 603245 [details] [diff] [review]
Word 'quinoa' added
Comment 11 :Ehsan Akhgari (busy, don't ask for review please) 2012-03-07 09:14:27 PST
Comment on attachment 603245 [details] [diff] [review]
Word 'quinoa' added

Thanks a lot, looks great!
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2012-03-07 09:27:25 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d086a890797
Comment 13 Ed Morley [:emorley] 2012-03-08 14:06:36 PST
https://hg.mozilla.org/mozilla-central/rev/4d086a890797

Thanks for the patch! :-)

Note You need to log in before you can comment on or make changes to this bug.