The default bug view has changed. See this FAQ.

JS Shell Workers broken (Assertion failure: rt->onOwnerThread(), at jsapi.cpp:6326)

RESOLVED FIXED in mozilla11

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: decoder, Assigned: luke)

Tracking

({assertion, testcase})

Trunk
mozilla11
x86
Linux
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I just wanted to give the workers in JS shell a try (mozilla-central revision 5ebeef1eabcb) but I only get this:

js> new Worker()
Assertion failure: rt->onOwnerThread(), at mozilla-central/js/src/jsapi.cpp:6326


I've built this shell with --enable-threadsafe and system NSPR.
(Reporter)

Comment 1

5 years ago
The first bad revision is:
changeset:   79916:31d13586087f
user:        Luke Wagner
date:        Fri Jul 01 14:11:31 2011 -0700
summary:     Bug 650411 - assert in debug/release builds that JSRuntime is only used in a single-threaded manner (r=jorendorff,sr=dmandelin)
(Assignee)

Comment 2

5 years ago
Created attachment 576167 [details] [diff] [review]
fix

Oops, I added a new JS_AbortIfWrongThread (under JS_SetContextThread) and forgot to run shell workers.
Assignee: jorendorff → luke
Status: NEW → ASSIGNED
Attachment #576167 - Flags: review?(jorendorff)
Attachment #576167 - Flags: review?(jorendorff) → review+
Duplicate of this bug: 704592
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/04f576b81e1a
Target Milestone: --- → mozilla11
https://hg.mozilla.org/mozilla-central/rev/04f576b81e1a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.