Last Comment Bug 704538 - Create telemetry probe to ascertain what proportion of users may prefer bug 695482's new 'open search in foreground' behaviour
: Create telemetry probe to ascertain what proportion of users may prefer bug 6...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
Depends on: 710562
Blocks: 695482
  Show dependency treegraph
 
Reported: 2011-11-22 10:35 PST by Ed Morley [:emorley]
Modified: 2013-11-12 00:57 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.89 KB, patch)
2011-11-28 07:13 PST, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch (2.85 KB, patch)
2011-11-29 07:02 PST, Dão Gottwald [:dao]
gavin.sharp: review+
taras.mozilla: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-11-22 10:35:05 PST
+++ This bug was initially created as a clone of Bug #695482 +++

Bug 695482 changed the default for the context menu "Search Google for <selection>" such that the new tab now opens in the foreground. Replies in that bug indicate that this may be disruptive for certain workflows and that the change should either be backed out or an about:config pref added to allow the user to revert to the former behaviour.

In order to make a decision, it was suggested a telemetry probe be added to find out how many people (under the old behaviour) immediately switch to the new tab, after using the context menu search feature.

Assigning to Dao, per conversation on #developers. Thanks Dao! :-)
Comment 1 Alex Limi (:limi) — Firefox UX Team 2011-11-22 20:28:08 PST
This isn't worth it. Pick a default, make it possible for an add-on to do something else, and leave it at that. We have much more important things to fix. :)
Comment 2 Dão Gottwald [:dao] 2011-11-22 23:31:50 PST
If you want us to pick the default arbitrarily, I'm leaning towards just reverting bug 695482, as it looks like there was no strong desire for this change while various people are annoyed by it. I don't think we should pick arbitrarily, as it shouldn't be too hard to get data.
Comment 3 Dão Gottwald [:dao] 2011-11-28 07:13:03 PST
Created attachment 577253 [details] [diff] [review]
patch
Comment 4 (dormant account) 2011-11-28 14:37:41 PST
What is MOZ_PHOENIX? Ie http://mxr.mozilla.org/mozilla/source/client.mk#658 true?
Comment 5 Dão Gottwald [:dao] 2011-11-29 04:56:29 PST
MOZ_PHOENIX is set when building desktop Firefox (browser/). I don't think http://mxr.mozilla.org/mozilla/source/client.mk#658 is relevant here. http://mxr.mozilla.org/mozilla-central/source/client.mk doesn't deal with MOZ_PHOENIX at all.
Comment 6 Dão Gottwald [:dao] 2011-11-29 07:02:48 PST
Created attachment 577601 [details] [diff] [review]
patch

updated to tip
Comment 7 (dormant account) 2011-11-29 10:36:46 PST
Comment on attachment 577601 [details] [diff] [review]
patch

r+ telemetry bits
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-02 11:58:05 PST
Comment on attachment 577601 [details] [diff] [review]
patch

>diff --git a/toolkit/components/telemetry/TelemetryHistograms.h b/toolkit/components/telemetry/TelemetryHistograms.h

>+HISTOGRAM(FX_CONTEXT_SEARCH_AND_TAB_SELECT, 0, 1, 2, BOOLEAN, "Firefox: Background tab was selected after searching from the context menu")

maybe tweak this to mention "within 5 seconds of searching from the context menu"?
Comment 10 Ed Morley [:emorley] 2011-12-04 07:20:48 PST
https://hg.mozilla.org/mozilla-central/rev/575d46b7119d

Note You need to log in before you can comment on or make changes to this bug.