Unlimited memory usage at the site.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: mathias.menzel, Assigned: waterson)

Tracking

Trunk
mozilla0.9.2
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; 0.8) Gecko/20010215
BuildID:    2001021503

if loading http://www.pcgames.de the system crashes totally on different pc's
and different kernelversions. (Tested 2.2.17 and 2.4)
Ive never seen something like this on Linux before SYSLOG: kernel: VM:
do_try_to_free_pages failed for XF86_SVGA; kernel: VM: do_try_to_free_pages
failed for kswapd           this goes on for every process which is running and
the reset key is only thing which works!!!!!!!!!!

Reproducible: Always
Steps to Reproduce:
Go to http://www.pcgames.de

Actual Results:  The complete System crashes!
And this on stable Linux

Expected Results:  show the page

part of the syslog:

 kernel: VM: do_try_to_free_pages failed for kswapd
 kernel: VM: do_try_to_free_pages failed for ascloc
 last message repeated 29 times
...
and so on

System hangs

Comment 1

18 years ago
*** Bug 70459 has been marked as a duplicate of this bug. ***
When I try this on linux, the browser starts using up memory very quickly,
allocating over 300M of memory within 10 seconds.  The symptoms described by the
reporter are a result of all system memory and swap being allocated (and waiting
a bit more would have caused the kernel's virtual memory system to kill the
mozilla process).

I see the following assertion:

###!!! ASSERTION: attempt to create circular frame list: 'aNextSibling != this',
file nsFrame.cpp, line 2200
###!!! Break: at file nsFrame.cpp, line 2200

right before the memory usage becomes ridiculous.

Attaching a stack trace of where the browser is (hit C-c in gdb and then 'where').
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen
Summary: Crashes totally the complete system!!! → Unlimited memory usage at the site.
Created attachment 26404 [details]
where we seem to be

Comment 4

18 years ago
Moving to m0.9.1 and reassigning to waterson.
Target Milestone: --- → mozilla0.9.1

Comment 5

18 years ago
Reassigning to waterson.
Assignee: karnaze → waterson

Updated

18 years ago
Blocks: 77421
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 6

18 years ago
I got "kernel: VM: do_try_to_free_pages failed" when I opened a very large
spam(over 1M).

(Assignee)

Comment 7

18 years ago
This (http://www.pcgames.de/) is working fine for me on a Linux build from
today, 2001-06-20. Could have been fixed by any number of things.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.