Last Comment Bug 704666 - hunspell/README_en_US.txt and hunspell/README_mozilla.txt have DOS newline characters
: hunspell/README_en_US.txt and hunspell/README_mozilla.txt have DOS newline ch...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla11
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 15:44 PST by Daniel Holbert [:dholbert]
Modified: 2012-02-01 13:57 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (27.22 KB, patch)
2011-11-22 15:45 PST, Daniel Holbert [:dholbert]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-11-22 15:44:58 PST
These two files:
http://mxr.mozilla.org/mozilla-central/source/extensions/spellcheck/locales/en-US/hunspell/README_mozilla.txt
http://mxr.mozilla.org/mozilla-central/source/extensions/spellcheck/locales/en-US/hunspell/README_en_US.txt
have DOS newline characters at the end of each line.

emacs shows these characters in the former file, but not in the latter for some reason (possibly because the former file has a mix of newline characters whereas the latter is entirely-DOS)

Per https://developer.mozilla.org/En/Mozilla_Coding_Style_Guide , the Mozilla codebase is standardized on Unix newline characters.

Patch coming up that converts the files, using the "fromdos" command-line utility (same as "dos2unix") on Ubuntu.
Comment 1 Daniel Holbert [:dholbert] 2011-11-22 15:45:50 PST
Created attachment 576329 [details] [diff] [review]
fix
Comment 2 Daniel Holbert [:dholbert] 2011-11-23 17:46:31 PST
Landed (as DONTBUILD):
 https://hg.mozilla.org/integration/mozilla-inbound/rev/6c56c78dc7a0
Comment 3 Ed Morley [:emorley] 2011-11-24 08:16:03 PST
https://hg.mozilla.org/mozilla-central/rev/6c56c78dc7a0

Note You need to log in before you can comment on or make changes to this bug.