Closed Bug 704669 Opened 10 years ago Closed 10 years ago

Crash [@ CrashInJS]

Categories

(Core :: JavaScript Engine, defect)

10 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, topcrash, Whiteboard: [native-crash], str-wanted, [QA+])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-18f36616-e1b3-4980-a122-897502111122 .
============================================================= 
Frame 	Module 	Signature [Expand] 	Source
0 	libc.so 	libc.so@0xcb1c 	
1 	libc.so 	libc.so@0x123d7 	
2 	libc.so 	libc.so@0x10bde 	
3 	libc.so 	libc.so@0x17bad 	
4 	libc.so 	libc.so@0x436d6 	
5 	libxul.so 	CrashInJS 	js/src/jsutil.cpp:95
6 	libxul.so 	JS_Assert 	js/src/jsutil.cpp:103
7 	libxul.so 	JS_AbortIfWrongThread 	js/src/jsapi.cpp:6326
8 	libxul.so 	js_NewContext 	js/src/jscntxt.cpp:401
9 	libxul.so 	JS_NewContext 	js/src/jsapi.cpp:1117
10 	libxul.so 	XPCJSContextStack::GetSafeJSContext 	js/xpconnect/src/XPCThreadContext.cpp:236
11 	libxul.so 	XPCCallContext::Init 	js/xpconnect/src/XPCCallContext.cpp:130
12 	libxul.so 	XPCCallContext::XPCCallContext 	js/xpconnect/src/XPCCallContext.cpp:63
13 	libxul.so 	GetContextFromObject 	js/xpconnect/src/XPCWrappedJSClass.cpp:543
14 	libxul.so 	nsXPCWrappedJSClass::DelegatedQueryInterface 	js/xpconnect/src/XPCWrappedJSClass.cpp:660
15 	libxul.so 	nsXPCWrappedJS::QueryInterface 	js/xpconnect/src/XPCWrappedJS.cpp:158
16 	libxul.so 	nsWeakReference::QueryReferent 	obj-firefox/xpcom/build/nsWeakReference.cpp:151
17 	libxul.so 	nsQueryReferent::operator 	obj-firefox/xpcom/build/nsWeakReference.cpp:88
18 	libxul.so 	nsCOMPtr_base::assign_from_helper 	obj-firefox/xpcom/build/nsCOMPtr.cpp:150
19 	libxul.so 	nsDocLoader::DoFireOnStateChange 	nsCOMPtr.h:760
20 	libxul.so 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1320
21 	libxul.so 	nsDocLoader::doStartURLLoad 	uriloader/base/nsDocLoader.cpp:904
22 	libxul.so 	nsDocLoader::OnStartRequest 	uriloader/base/nsDocLoader.cpp:591
23 	libxul.so 	nsLoadGroup::AddRequest 	netwerk/base/src/nsLoadGroup.cpp:612
24 	libxul.so 	imgRequestProxy::AddToLoadGroup 	image/src/imgRequestProxy.cpp:222
25 	libxul.so 	imgLoader::LoadImage 	image/src/imgLoader.cpp:1781
26 	libxul.so 	nsContentUtils::LoadImage 	content/base/src/nsContentUtils.cpp:2385
27 	libxul.so 	nsImageLoadingContent::LoadImage 	content/base/src/nsImageLoadingContent.cpp:789
28 	libxul.so 	nsImageLoadingContent::LoadImage 	content/base/src/nsImageLoadingContent.cpp:706
29 	libxul.so 	nsHTMLImageElement::MaybeLoadImage 	content/html/content/src/nsHTMLImageElement.cpp:572
30 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:345
31 	libxul.so 	nsContentUtils::RemoveScriptBlocker 	content/base/src/nsContentUtils.cpp:4449
32 	libxul.so 	nsViewManager::Refresh 	nsContentUtils.h:2018
33 	libxul.so 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:885
34 	libxul.so 	HandleEvent 	view/src/nsView.cpp:159
35 	libxul.so 	nsWindow::DispatchEvent 	widget/src/android/nsWindow.cpp:700
36 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1098
37 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1145
38 	libxul.so 	nsWindow::DrawToFile 	widget/src/android/nsWindow.cpp:837
39 	libxul.so 	DrawToFileRunnable::Run 	widget/src/android/nsWindow.cpp:806
40 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
41 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
42 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:272
43 	libnspr4.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:187
44 	libc.so 	libc.so@0x11e3a 	
45 	libc.so 	libc.so@0x11a16 

More Reports:
https://crash-stats.mozilla.com/report/list?product=Fennec&query_search=signature&query_type=contains&query=CrashInJS&reason_type=contains&date=11%2F22%2F2011%2015%3A59%3A34&range_value=2&range_unit=weeks&hang_type=any&process_type=any&do_query=1&admin=1&signature=CrashInJS
Crash Signature: [@ CrashInJS] → [@ CrashInJS] [@ tkill]
Crash Signature: [@ CrashInJS] [@ tkill] → [@ CrashInJS] [@ tkill] [@ kill]
Keywords: topcrash
Whiteboard: [native-crash] → [native-crash], str-wanted, [QA+]
Bug 707381 is a dup of this bug as well.  some strs are listed.
Depends on: 706009
Depends on: 715713
Dupe of bug 715757?
No, this looks like a separate bug.
I see one crash in Fennec XUL 11.0a1, bp-6cb982c8-8d77-452e-92cb-85a242111225, but with a different stack.
You need to log in before you can comment on or make changes to this bug.