Last Comment Bug 704820 - Simplify nsContentUtils::ReportToConsole
: Simplify nsContentUtils::ReportToConsole
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Masatoshi Kimura [:emk]
:
Mentors:
Depends on: 701787
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 06:44 PST by Masatoshi Kimura [:emk]
Modified: 2012-02-01 14:00 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (55.34 KB, patch)
2011-11-23 06:47 PST, Masatoshi Kimura [:emk]
no flags Details | Diff | Review
patch (55.39 KB, patch)
2011-11-29 06:03 PST, Masatoshi Kimura [:emk]
bugs: review+
Details | Diff | Review
Simplify nsContentUtils::ReportToConsole. r=smaug (56.49 KB, patch)
2011-12-09 10:21 PST, Masatoshi Kimura [:emk]
VYV03354: review+
Details | Diff | Review

Description Masatoshi Kimura [:emk] 2011-11-23 06:44:39 PST
Most callers do not set params, paramsLength, URI, source, lineNumber.
columnNumber is not used at all!
Most callers do not set non-zero windowID.
So I propose the follwing changes:
- Move flags, category and doc params onto other rarer used params and make the rest params optional.
- Remove the windowID version method.
Comment 1 Masatoshi Kimura [:emk] 2011-11-23 06:47:32 PST
Created attachment 576481 [details] [diff] [review]
patch
Comment 2 Masatoshi Kimura [:emk] 2011-11-23 06:50:44 PST
Apply this on top of bug 701787's patch.
Comment 3 :Ms2ger 2011-11-23 06:54:41 PST
Looks like the only caller that passes a raw window ID is the nsIDOMWindowInternal one, so it's probably fine to remove that variant.
Comment 4 Masatoshi Kimura [:emk] 2011-11-29 06:03:42 PST
Created attachment 577582 [details] [diff] [review]
patch

Updated to tip
Comment 5 Dão Gottwald [:dao] 2011-11-29 08:21:35 PST
Please mark this for check-in once the dependencies are cleared.
Comment 6 Masatoshi Kimura [:emk] 2011-12-09 10:21:18 PST
Created attachment 580453 [details] [diff] [review]
Simplify nsContentUtils::ReportToConsole. r=smaug

Updated to tip
Comment 7 Masatoshi Kimura [:emk] 2011-12-09 10:22:02 PST
The dependent bug has been fixed.
Comment 8 Ed Morley [:emorley] 2011-12-15 02:34:12 PST
In my queue with a few other checkin-neededs that are being sent to try first and then onto inbound :-)
https://tbpl.mozilla.org/?tree=Try&rev=fd440327d5e4
Comment 10 Ed Morley [:emorley] 2011-12-16 06:19:23 PST
https://hg.mozilla.org/mozilla-central/rev/e8659eb419fb

Note You need to log in before you can comment on or make changes to this bug.