File upload silently fails with bogus $TMPDIR

VERIFIED DUPLICATE of bug 15320

Status

()

--
major
VERIFIED DUPLICATE of bug 15320
18 years ago
18 years ago

People

(Reporter: jwbaker, Assigned: pollmann)

Tracking

Trunk
mozilla0.9.1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
File upload is broken in Linux 2001-02-28-08 build and earlier.  I cannot attach
files in Bugzilla, upload HTML to http://validator.w3.org/file-upload.html, nor
can I attach files to email using webmail sites.

Marking dogfood because of the bugzilla thing.
(Reporter)

Comment 1

18 years ago
BTW, the behavior is that the "Submit" button on the Buzilla attachment for
simply has no visible effect.
Keywords: dogfood

Comment 2

18 years ago
i just uploaded a txt attachment via bugzilla-form w/2001022721 linux, so this
must be a very recent regression.
(Reporter)

Comment 3

18 years ago
Created attachment 26423 [details]
Test
(Reporter)

Comment 4

18 years ago
Created attachment 26424 [details]
test
(Reporter)

Comment 5

18 years ago
I nailed the problem down more.  When the environment variable TMPDIR points to
a nonexistant location, Mozilla's file upload fails silently.
Keywords: dogfood
Summary: File upload does nothing → File upload silently fails with bogus $TMPDIR
Setting milestone to mozilla0.9.1.
Reassigned to pollmann.
Assignee: rods → pollmann
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 7

18 years ago
Will fix with 15320.

*** This bug has been marked as a duplicate of 15320 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
verifying per developer's coments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.