Last Comment Bug 705072 - www.wolframalpha.com - The site does not work
: www.wolframalpha.com - The site does not work
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
:
Mentors:
http://www.wolframalpha.com/input/?i=...
: 705216 (view as bug list)
Depends on:
Blocks: 651072
  Show dependency treegraph
 
Reported: 2011-11-24 02:21 PST by Alice0775 White
Modified: 2011-11-25 13:00 PST (History)
7 users (show)
hsivonen: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Limit HTML support to responseType == "document" only (6.43 KB, patch)
2011-11-24 03:58 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
no flags Details | Diff | Splinter Review
Limit HTML support to responseType == "document" only, get rid of now moot progress event stalling (9.51 KB, patch)
2011-11-24 05:38 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bugs: review+
Details | Diff | Splinter Review

Description Alice0775 White 2011-11-24 02:21:25 PST
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/3c8147998124
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111123 Firefox/11.0a1 ID:20111123031034

The site does not work.
See forum http://forums.mozillazine.org/viewtopic.php?p=11496539#p11496539

Reproducible: Always

Steps to Reproduce:
1 Start Firefox with clean profile
2 Open ex. http://www.wolframalpha.com/input/?i=2010+AD , http://www.wolframalpha.com/input/?i=1

Actual Results:
  The site does not work. Progress bar indicates loading forever.


Expected Results:
  The site should work.

Regression window(m-i)
Works;
http://hg.mozilla.org/integration/mozilla-inbound/rev/909ff89ee487
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111120 Firefox/11.0a1 ID:20111121002958
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0c4d3b7be17e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111120 Firefox/11.0a1 ID:20111121034259
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=909ff89ee487&tochange=0c4d3b7be17e
Comment 1 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-24 03:58:29 PST
Created attachment 576715 [details] [diff] [review]
Limit HTML support to responseType == "document" only

Limit HTML support to responseType == "document" only per IRC approval from smaug and annevk.
Comment 2 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-24 05:38:05 PST
Created attachment 576738 [details] [diff] [review]
Limit HTML support to responseType == "document" only, get rid of now moot progress event stalling
Comment 3 Masatoshi Kimura [:emk] 2011-11-24 06:35:02 PST
HTMLSyncXHRWarning will no longer be required because sync XHR cannot set .responseType in the first place.
Comment 4 Masatoshi Kimura [:emk] 2011-11-24 06:36:19 PST
(In reply to Masatoshi Kimura [:emk] from comment #3)
> HTMLSyncXHRWarning will no longer be required because sync XHR cannot set
> .responseType in the first place.
... after bug 701787 has been fixed.
Comment 5 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-24 06:37:45 PST
(In reply to Masatoshi Kimura [:emk] from comment #4)
> (In reply to Masatoshi Kimura [:emk] from comment #3)
> > HTMLSyncXHRWarning will no longer be required because sync XHR cannot set
> > .responseType in the first place.
> ... after bug 701787 has been fixed.

Yeah, but that depends on the landing order. We should probably have a clean-up bug after both have landed.
Comment 6 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-24 07:31:04 PST
Thanks for finding the bug. Thanks for the r+. Landed.
https://hg.mozilla.org/integration/mozilla-inbound/rev/76273d6c90ec
Comment 7 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-24 23:29:28 PST
*** Bug 705216 has been marked as a duplicate of this bug. ***
Comment 8 Mounir Lamouri (:mounir) 2011-11-25 02:19:15 PST
https://hg.mozilla.org/mozilla-central/rev/76273d6c90ec

Note You need to log in before you can comment on or make changes to this bug.