Last Comment Bug 705110 - Triggering DOMAttrModified event handler causes "Use of getAttributeNodeNS() is deprecated" warning
: Triggering DOMAttrModified event handler causes "Use of getAttributeNodeNS() ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Masatoshi Kimura [:emk]
:
:
Mentors:
Depends on:
Blocks: abp 661327
  Show dependency treegraph
 
Reported: 2011-11-24 05:05 PST by Wladimir Palant
Modified: 2012-02-28 09:53 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (328 bytes, text/html)
2011-11-24 05:05 PST, Wladimir Palant
no flags Details
Stop warning spam (4.80 KB, patch)
2012-02-23 11:14 PST, Masatoshi Kimura [:emk]
bugs: review+
Details | Diff | Splinter Review

Description Wladimir Palant 2011-11-24 05:05:19 PST
Created attachment 576728 [details]
Testcase

I managed to narrow down the source of the "Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead." warning that I see occasionally - looks like having a DOMAttrModified event listener around causes that warning if the event listener is triggered. See attached testcase that does nothing other than adding this event listener and triggering it. This is enough to cause this warning to pop up in Error Console. Tested with Firefox 8 and current 11.0a1 nightly on Windows 7 x64.
Comment 1 Olli Pettay [:smaug] (way behind * queues, especially ni? queue) 2011-11-24 05:08:11 PST
This is kind of ok, since also DOMAttrModified is deprecated.

Need to add a warning about using DOMAttrModified once we have the replacement done.
Comment 2 Wladimir Palant 2011-11-24 05:13:46 PST
I'm using it because it appears to be the only way to get notified when <xul:tree> finishes editing ("editing" attribute is removed).
Comment 3 Ian Nartowicz 2012-01-13 08:16:34 PST
DOMAttrModified deprecated?  Maybe there needs to be a replacement first?
Comment 4 Stefan Sitter 2012-02-16 13:02:31 PST
The Lightning calendaring extension for Thunderbird triggers the same warning because it is using DOMAttrModified too (http://mxr.mozilla.org/comm-central/search?string=DOMAttrModified&find=/calendar/)

When is it going to be removed? What should be used instead?
Comment 5 Masatoshi Kimura [:emk] 2012-02-23 11:14:52 PST
Created attachment 600100 [details] [diff] [review]
Stop warning spam

We shouldn't spam the warning until the replacement is available. Even if we want some kinds of warnings, the current message does not indicate what actually cause the warning.
Comment 6 Mozilla RelEng Bot 2012-02-27 05:19:09 PST
Autoland Patchset:
	Patches: 600100
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=f2ffdd8bfda3
Try run started, revision f2ffdd8bfda3. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=f2ffdd8bfda3
Comment 7 Mozilla RelEng Bot 2012-02-27 09:31:53 PST
Try run for f2ffdd8bfda3 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f2ffdd8bfda3
Results (out of 215 total builds):
    exception: 4
    success: 175
    warnings: 21
    failure: 15
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-f2ffdd8bfda3
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-02-27 16:00:07 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/547e2b0fbe83
Comment 9 Matt Brubeck (:mbrubeck) 2012-02-28 09:53:45 PST
https://hg.mozilla.org/mozilla-central/rev/547e2b0fbe83

Note You need to log in before you can comment on or make changes to this bug.