Last Comment Bug 705166 - Entering text in inputs fields has regressed in performance; lagged input
: Entering text in inputs fields has regressed in performance; lagged input
Status: VERIFIED FIXED
: inputmethod, perf, regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 major (vote)
: ---
Assigned To: Alex Pakhotin (:alexp)
:
Mentors:
: 705266 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 10:34 PST by Remus Pop (:RemusPop)
Modified: 2012-01-09 10:07 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Backing out bug 703821 (1.82 KB, patch)
2011-11-29 16:22 PST, Alex Pakhotin (:alexp)
dougt: feedback-
Details | Diff | Review

Description Remus Pop (:RemusPop) 2011-11-24 10:34:41 PST
Tried to file a bug to bugzilla but typing was really slow, getting 0 fps most of the time.
Also when typing a word, capital letters would come up all of a sudden making typing almost impossible.
I am running nightly in android 2.2.1 in huawei ideos s7.
Comment 1 Aaron Train [:aaronmt] 2011-11-24 10:42:38 PST
I can reproduce this on the the Galaxy Tab 10.1 (Android 3.1) using the Quick Search field, alongside my Nexus S (Android 2.3.6).

--
20111124085716
http://hg.mozilla.org/projects/birch/rev/88679504d1df
Comment 2 Aaron Train [:aaronmt] 2011-11-25 06:45:35 PST
*** Bug 705266 has been marked as a duplicate of this bug. ***
Comment 3 Cristian Nicolae (:xti) 2011-11-25 08:39:16 PST
This issue doesn't occur on:
20111122221128
http://hg.mozilla.org/projects/birch/rev/5b13d1ed6376

but it occurs on:
20111123205632
http://hg.mozilla.org/projects/birch/rev/98861dbb3277

Possible range:
http://hg.mozilla.org/projects/birch/pushloghtml?fromchange=5b13d1ed6376&tochange=98861dbb3277
Comment 4 Cristian Nicolae (:xti) 2011-11-25 09:48:58 PST
This issue occurs on:
20111123111528
http://hg.mozilla.org/projects/birch/rev/8fcdb0e7131d

Perhaps on of the landed patches from Bug 703141 causes this bug.
Comment 5 Remus Pop (:RemusPop) 2011-11-26 10:18:14 PST
Also reproducible in Samsung Galaxy SII with Android 2.3.3, but capital letters or double space issues do not exist.
Comment 6 Aaron Train [:aaronmt] 2011-11-28 08:04:38 PST
Today typing into google.com input:

W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
I/InputDispatcher(  240): Application is not responding: Window{4173eb48 InputMethod paused=false}.  5005.7ms since event, 5005.5ms since wait started
I/WindowManager(  240): Input event dispatching timed out sending to InputMethod
W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
D/dalvikvm( 4410): GC_CONCURRENT freed 1778K, 17% free 15263K/18375K, paused 2ms+5ms
W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
I/InputDispatcher(  240): Application is not responding: Window{4173eb48 InputMethod paused=false}.  9768.9ms since event, 5002.2ms since wait started
I/WindowManager(  240): Input event dispatching timed out sending to InputMethod
W/InputConnectionWrapper.ICC(  406): Timed out waiting on IInputContextCallback
I/InputConnectionWrapper.ICC(  406): Got out-of-sequence callback 1453 (expected 1459) in setTextBeforeCursor, ignoring.
D/GeckoInputConnection( 4410): IME: getTextAfterCursor
D/GeckoInputConnection( 4410): IME: getCursorCapsMode
D/GeckoInputConnection( 4410): IME: setComposingText
I/InputConnectionWrapper.ICC(  406): Got out-of-sequence callback 1454 (expected 1459) in setTextAfterCursor, ignoring.
I/InputConnectionWrapper.ICC(  406): Got out-of-sequence callback 1455 (expected 1459) in setCursorCapsMode, ignoring.
D/GeckoInputConnection( 4410): IME: getCursorCapsMode

This is pretty bad.

--
Samsung Nexus S (Android 4.0.1)
20111128040211
http://hg.mozilla.org/projects/birch/rev/aa6ad7ab9b43
Comment 7 Aaron Train [:aaronmt] 2011-11-29 07:40:28 PST
Another URL where it's particularly really bad, amazon.com search with an 11 second timeout on typing a few words.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-29 09:00:59 PST
Alex, can you see what could be happening here? Is it an IME issue or a reapint issue?
Comment 9 Alex Pakhotin (:alexp) 2011-11-29 11:15:28 PST
I've got a different regression window. Input is fine in the build 20111118040220, but is slow in the next nightly 20111119040305.

Tested on Nexus One. In the latter build the typed text appears with a very noticeable delay - I already stopped hammering the VKB, but the letters keep appearing one by one for several more seconds.

I will look further into this today.
Comment 10 Alex Pakhotin (:alexp) 2011-11-29 15:41:20 PST
Apparently the performance regression was caused by the bug 703821. Backing out the change ea5e1f4e996a fixes this problem.

Aaron, could you please try my build with that change backed out and see if it behaves better in your scenarios? It is here: http://people.mozilla.org/~alexp/bug/705166-lagged-input/fennec-11.0a1.en-US.android-arm.apk
Thanks.
Comment 11 Aaron Train [:aaronmt] 2011-11-29 16:07:01 PST
(In reply to Alex Pakhotin (:alexp) from comment #10)
> http://people.mozilla.org/~alexp/bug/705166-lagged-input/fennec-11.0a1.en-US.
> android-arm.apk

Indeed fixed in this build.
Comment 12 Alex Pakhotin (:alexp) 2011-11-29 16:22:18 PST
Created attachment 577789 [details] [diff] [review]
Backing out bug 703821

Thank you for the confirmation, Aaron.

This patch just backs out the change ea5e1f4e996a.
Sounds like bug 703821 needs an alternative solution.

Patrick, what do you think?
Comment 13 Patrick Walton (:pcwalton) 2011-11-29 16:23:31 PST
We can't take this patch as it stands. It's better to have slow input fields than to have random display corruption all over the place.
Comment 14 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-29 16:29:51 PST
Will bug 701623 (and bug 704575) fix this situation?
Comment 15 Chris Lord [:cwiiis] 2011-11-30 06:26:38 PST
(In reply to Mark Finkle (:mfinkle) from comment #14)
> Will bug 701623 (and bug 704575) fix this situation?

It ought to do, yes. I'll have a look at this.
Comment 16 Chris Lord [:cwiiis] 2011-11-30 08:19:03 PST
I've fixed bug #704575, so if this could be re-tested, that'd be useful.
Comment 17 Aaron Train [:aaronmt] 2011-11-30 11:30:00 PST
(In reply to Chris Lord [:cwiiis] from comment #16)
> I've fixed bug #704575, so if this could be re-tested, that'd be useful.

With https://hg.mozilla.org/projects/birch/rev/c9164cc832de, it's definately better but still somewhat slower than I can recall (at least on my Nexus S 2.3.6).

Perhaps others want to try as well.
Comment 18 Alex Pakhotin (:alexp) 2011-11-30 12:26:47 PST
(In reply to Chris Lord [:cwiiis] from comment #16)
> I've fixed bug #704575, so if this could be re-tested, that'd be useful.

That patch makes input work much-much better! On the Asus Transformer I don't see basically any lag: the typed text appears right away even with keyboard being mashed, while without the patch it was so slow that the entered characters queued up and were appearing for several seconds after you stopped typing.
Comment 19 Alex Pakhotin (:alexp) 2011-12-01 13:22:58 PST
I guess this bug is fixed in the latest nightly.
Aaron, can you confirm please?
Comment 20 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 14:27:18 PST
Working fine for me too
Comment 21 Alex Pakhotin (:alexp) 2011-12-08 16:47:07 PST
As Brand noticed today, WORKSFORME is not a correct resolution for this one. The bug was actually fixed by the patch in bug 704575.
Comment 22 Alex Pakhotin (:alexp) 2011-12-08 16:48:26 PST
> As Brand noticed today

Err, I meant Brad. :)
Comment 23 Carla Nadastean 2011-12-09 02:32:18 PST
Retested with:
Mozilla/5.0(Android; Linux armv7l; rv:11.0a1) Gecko/20111208 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire Z (Android 2.3)

Bug no longer reproducible. Verifying.

Note You need to log in before you can comment on or make changes to this bug.