Last Comment Bug 705191 - IonMonkey: jit-test --ion flag broken on TBPL
: IonMonkey: jit-test --ion flag broken on TBPL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
Depends on:
Blocks: IonMonkey
  Show dependency treegraph
 
Reported: 2011-11-24 13:16 PST by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2011-11-28 12:06 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (4.62 KB, patch)
2011-11-28 02:17 PST, Jan de Mooij [:jandem] (PTO until July 31)
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2011-11-24 13:16:17 PST
Since --jitflags defaults to m,mn now, we no longer look at the --ion flag.

A related issue is that we run each test 2^5 = 32 times now with --ion. This number doubles whenever we add a new flag (-m, -n?). It's necessary to run tests with different optimizations and register allocators, but this exponential behavior seems a bit excessive.
Comment 1 Nicolas B. Pierron [:nbp] 2011-11-24 14:30:52 PST
I agree, in addition some tests are only relevant for a specific set of options.  Last example I have is a test which is only useful when ran with "--ion -n" options.  Most of the tests we have should run with "--ion --ion-eager" otherwise we are only testing the interpreter.
Comment 2 David Anderson [:dvander] 2011-11-24 20:39:55 PST
Once we have OSR, we could remove --ion-eager from the test matrix. We do catch valid bugs with all the options, so I think it's valuable for TBPL if nothing else. When testing locally we don't have to use --ion (I use --jitflags=, --args="--ion-eager", so we could have --ion-tbpl and --ion as shorthand for the defaults).
Comment 3 Jan de Mooij [:jandem] (PTO until July 31) 2011-11-25 00:27:59 PST
Yes, --ion-tbpl sounds good.
Comment 4 Jan de Mooij [:jandem] (PTO until July 31) 2011-11-28 02:17:59 PST
Created attachment 577210 [details] [diff] [review]
Fix

Changes --ion to run tests with the --ion flag and add --ion-tbpl to run tests with all IM options. These options ignore --jitflags so this should fix the tinderbox problem.

I considered supporting "--jitflags=n --ion", but it may be confusing since jitflags defaults to m,mn. We could change the default --jitflags value, but we probably don't want to diverge from mozilla-central too much.

Once we have on stack invalidation, --ion should probably run tests with both --ion and --ion -n.
Comment 5 Jan de Mooij [:jandem] (PTO until July 31) 2011-11-28 12:06:40 PST
http://hg.mozilla.org/projects/ionmonkey/rev/18aacf4a410e

Note You need to log in before you can comment on or make changes to this bug.