Last Comment Bug 705247 - IonMonkey: getgname does not need a shape guard with TI
: IonMonkey: getgname does not need a shape guard with TI
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
:
Mentors:
Depends on:
Blocks: IonMonkey
  Show dependency treegraph
 
Reported: 2011-11-25 02:53 PST by Jan de Mooij [:jandem]
Modified: 2011-11-29 02:55 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.67 KB, patch)
2011-11-25 03:03 PST, Jan de Mooij [:jandem]
no flags Details | Diff | Splinter Review
Patch (4.71 KB, patch)
2011-11-25 03:32 PST, Jan de Mooij [:jandem]
dvander: review+
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2011-11-25 02:53:30 PST
Since our shape guards are kind of broken now (on purpose, waiting for ObjShrink), we need this to run (a modified version of) bitwise-and.
Comment 1 Jan de Mooij [:jandem] 2011-11-25 03:03:20 PST
Created attachment 576895 [details] [diff] [review]
Patch

We can probably get rid of some TypeOracle methods. I'll get to it after getelem/setelem lands to avoid updating the patch David is reviewing.
Comment 2 Jan de Mooij [:jandem] 2011-11-25 03:32:12 PST
Created attachment 576897 [details] [diff] [review]
Patch

Clarify the abort message a bit. According to the isOwnProperty comment we don't abort for properties that are non-writable etc on creation.
Comment 3 Jan de Mooij [:jandem] 2011-11-29 02:55:05 PST
Pushed:

http://hg.mozilla.org/projects/ionmonkey/rev/7100a5b53a31

Note You need to log in before you can comment on or make changes to this bug.