Last Comment Bug 705276 - Split style inspector CSS between content & document CSS
: Split style inspector CSS between content & document CSS
Status: RESOLVED FIXED
[computedview][ruleview]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: Firefox 13
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
:
: Patrick Brosset <:pbro>
Mentors:
Depends on: 703643
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 06:49 PST by Michael Ratcliffe [:miker] [:mratcliffe]
Modified: 2012-03-12 13:00 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (9.15 KB, patch)
2012-03-08 03:06 PST, Michael Ratcliffe [:miker] [:mratcliffe]
dao+bmo: review-
Details | Diff | Splinter Review
Now depends on bug 703643 (9.07 KB, patch)
2012-03-08 07:50 PST, Michael Ratcliffe [:miker] [:mratcliffe]
dao+bmo: review-
Details | Diff | Splinter Review
Addressed reviewers comments (7.92 KB, patch)
2012-03-08 08:46 PST, Michael Ratcliffe [:miker] [:mratcliffe]
paul: review-
Details | Diff | Splinter Review
Patch (12.77 KB, patch)
2012-03-09 05:36 PST, Michael Ratcliffe [:miker] [:mratcliffe]
paul: review+
Details | Diff | Splinter Review
A little optimisation (12.64 KB, patch)
2012-03-11 13:39 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details | Diff | Splinter Review

Description Michael Ratcliffe [:miker] [:mratcliffe] 2011-11-25 06:49:49 PST
We should split style inspector CSS between content & document CSS
Comment 1 Michael Ratcliffe [:miker] [:mratcliffe] 2012-01-11 04:05:12 PST
Bug triage, filter on PEGASUS.
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-08 03:06:56 PST
Created attachment 604002 [details] [diff] [review]
Patch
Comment 3 Dão Gottwald [:dao] 2012-03-08 04:36:37 PST
Comment on attachment 604002 [details] [diff] [review]
Patch

>--- a/browser/devtools/styleinspector/styleinspector.css
>+++ b/browser/devtools/styleinspector/styleinspector.css

>+:root {
>+  -moz-appearance: none;

>+.expander {
>+  -moz-appearance: treetwisty;

>+.expander[open] {
>+  -moz-appearance: treetwistyopen;

>+#propertyContainer {
>+  border-collapse: collapse;

This looks like styling rather than content CSS.
Comment 4 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-08 07:50:15 PST
Created attachment 604068 [details] [diff] [review]
Now depends on bug 703643
Comment 5 Dão Gottwald [:dao] 2012-03-08 07:55:05 PST
Comment on attachment 604068 [details] [diff] [review]
Now depends on bug 703643

see comment 3...
Comment 6 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-08 08:46:47 PST
Created attachment 604084 [details] [diff] [review]
Addressed reviewers comments
Comment 7 Paul Rouget [:paul] 2012-03-09 04:17:21 PST
Comment on attachment 604084 [details] [diff] [review]
Addressed reviewers comments

You forgot to remove #propertyContainer from the theme code.
There's still some "display" properties for the rule-view related code.
Comment 8 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-09 05:36:35 PST
Created attachment 604386 [details] [diff] [review]
Patch

Fixed
Comment 9 Paul Rouget [:paul] 2012-03-09 06:48:34 PST
Comment on attachment 604386 [details] [diff] [review]
Patch

Review of attachment 604386 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/styleinspector/styleinspector.css
@@ +48,5 @@
> +}
> +
> +.property-name {
> +  display: inline-block;
> +}

add an empty line here.

@@ +92,5 @@
> +}
> +
> +.ruleview-propertyname {
> +  display: inline-block;
> +}

Group the `display:inline-block` related rules together.
Comment 10 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-11 13:39:32 PDT
Created attachment 604787 [details] [diff] [review]
A little optimisation

Done
Comment 11 Panos Astithas [:past] 2012-03-12 04:17:08 PDT
https://hg.mozilla.org/integration/fx-team/rev/6dea789aeb4b
Comment 12 Tim Taubert [:ttaubert] 2012-03-12 13:00:50 PDT
https://hg.mozilla.org/mozilla-central/rev/6dea789aeb4b

Note You need to log in before you can comment on or make changes to this bug.