Last Comment Bug 705356 - Remove JSOPTION_JIT and JSOPTION_PROFILING
: Remove JSOPTION_JIT and JSOPTION_PROFILING
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Ryan VanderMeulen [:RyanVM]
:
Mentors:
Depends on: 604216 698201
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 13:11 PST by Ryan VanderMeulen [:RyanVM]
Modified: 2011-11-29 04:58 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (9.47 KB, patch)
2011-11-25 13:38 PST, Ryan VanderMeulen [:RyanVM]
no flags Details | Diff | Review
Remove JSOPTION_JIT and JSOPTION_PROFILING (25.10 KB, patch)
2011-11-25 14:24 PST, Ryan VanderMeulen [:RyanVM]
dvander: review+
Details | Diff | Review

Description Ryan VanderMeulen [:RyanVM] 2011-11-25 13:11:34 PST
JSOPTION_JIT is unused now that TM has been removed. References to it should be removed.
Comment 1 Ryan VanderMeulen [:RyanVM] 2011-11-25 13:38:21 PST
Created attachment 576995 [details] [diff] [review]
Patch

dvander, can you review this?

Also, I'm wondering if some of these removals should have JSOPTION_METHODJIT and/or JSOPTION_TYPE_INFERENCE set instead of outright removal. Comments?
Comment 2 Ryan VanderMeulen [:RyanVM] 2011-11-25 13:43:51 PST
JSOPTION_PROFILING should probably go too, now that I think about it.
Comment 3 Mozilla RelEng Bot 2011-11-25 14:00:50 PST
Try run for c0b6fe6eb324 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=c0b6fe6eb324
Results (out of 13 total builds):
    exception: 7
    failure: 6
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ryanvm@gmail.com-c0b6fe6eb324
Comment 4 Ryan VanderMeulen [:RyanVM] 2011-11-25 14:24:45 PST
Created attachment 577006 [details] [diff] [review]
Remove JSOPTION_JIT and JSOPTION_PROFILING

This patch also removes the profiling prefs. Try results incoming.
Comment 5 Ryan VanderMeulen [:RyanVM] 2011-11-25 15:44:56 PST
David, this apparently blew up xpcshell tests. I can't figure out why, though.
https://tbpl.mozilla.org/?tree=Try&rev=24e506407c7f
Comment 6 Mozilla RelEng Bot 2011-11-25 18:00:46 PST
Try run for 24e506407c7f is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=24e506407c7f
Results (out of 190 total builds):
    exception: 1
    success: 142
    warnings: 41
    failure: 6
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ryanvm@gmail.com-24e506407c7f
Comment 7 Ryan VanderMeulen [:RyanVM] 2011-11-25 18:38:31 PST
Of course! It was probably dying because xpcshell was being invoked with -j still. Pretty funny since I had posted a patch to bug 604216 just prior to filing this one to change that to -m -n. Trying this push again with both patches this time.
Comment 8 Mozilla RelEng Bot 2011-11-25 22:10:20 PST
Try run for d7cd75718272 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=d7cd75718272
Results (out of 189 total builds):
    exception: 1
    success: 164
    warnings: 19
    failure: 5
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ryanvm@gmail.com-d7cd75718272
Comment 9 Ryan VanderMeulen [:RyanVM] 2011-11-25 22:17:06 PST
xpcshell tests are all green now!
Comment 10 Daniel Holbert [:dholbert] 2011-11-28 15:01:46 PST
(note that bug 604216 landed on m-i earlier today)

Landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d984d11bffea
Comment 11 Marco Bonardo [::mak] 2011-11-29 04:58:16 PST
https://hg.mozilla.org/mozilla-central/rev/d984d11bffea

Note You need to log in before you can comment on or make changes to this bug.