Last Comment Bug 705358 - Over scroll / scroll should not exist when page is fully zoomed out and all the content is in the view port.
: Over scroll / scroll should not exist when page is fully zoomed out and all t...
Status: VERIFIED FIXED
ux feature
: uiwanted
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Patrick Walton (:pcwalton)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 13:21 PST by Patryk Adamczyk [:patryk] UX
Modified: 2013-12-27 14:25 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
example of the overscroll I am referring to in the description. (54.19 KB, image/png)
2011-11-25 13:21 PST, Patryk Adamczyk [:patryk] UX
no flags Details
Proposed patch. (3.00 KB, patch)
2011-12-07 19:50 PST, Patrick Walton (:pcwalton)
bugmail: review+
Details | Diff | Splinter Review

Description Patryk Adamczyk [:patryk] UX 2011-11-25 13:21:57 PST
Created attachment 576992 [details]
example of the overscroll I am referring to in the description.

When all the content is displayed in the view port and the display is fully zoomed out (ie. loading about:firefox) horizontal scroll or over scroll should not exist > Reference iOS or Android's native browser. 

Vertical over scroll should be minimized and ideally removed, pull down over scroll has become a more common touch gesture for refreshing content so this would be a nice feature in web apps, but could be useful throughout the browser. 

Over scroll should have a purpose and not just be playful, minimizing the elasticity will create a more solid feel.
Comment 1 Chris Lord [:cwiiis] 2011-12-01 12:21:56 PST
I agree with this, though we'll need some UX comment.

Generally, I think our default behaviour should match default android before it matches iOS/Samsung tweaks (see bug #705246), but these can be dealt with separately.
Comment 2 Patryk Adamczyk [:patryk] UX 2011-12-02 06:37:08 PST
This is coming from UX (from me and Madhava).
I should have been clear, yes the behaviour should be the same as the android browser meaning at zoom out (if the entire page's content is in the view port), no over scroll whatever.

I should have been clearer in the initial bug comment.
Comment 3 Patrick Walton (:pcwalton) 2011-12-02 08:51:23 PST
Agreed that we should match iOS here. I was concerned when the native about:home landed that its native-ness leaks through to the user, since overscroll works in content but doesn't work for the native about:home. I think that this would fix this problem, since about:home would be treated the same as any other page with fully visible content. (about:home does have scrollable "iframe" workalikes, but those shouldn't overscroll anyway.)
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-12-07 15:05:07 PST
I don't understand this bug, either we want over scroll or not. I'm marking this as won't fix. Madhava, if you reopen, please adjust the summary to be clear about what you want.
Comment 5 Patrick Walton (:pcwalton) 2011-12-07 19:50:29 PST
Created attachment 579951 [details] [diff] [review]
Proposed patch.

We talked about this in the war room today. Overscroll shouldn't happen on axes that are fully zoomed out. No OS, not even iOS, does this.

Here's a patch that implements the behavior.
Comment 6 Patrick Walton (:pcwalton) 2011-12-07 19:54:55 PST
To be more clear, here's an example use case: If you open a mobile site that has no content off to the left or right of the screen, you shouldn't be able to overscroll to the left or right, because the site is asking for a vertical layout. Similar logic applies to a desktop site that's fully zoomed out to the width of the device.

Think of it as an extra unbreakable axis lock: when there's no reason the user could possibly want to scroll in a direction, we should just lock that direction.

As mentioned, this mirrors iOS's behavior.
Comment 7 Patryk Adamczyk [:patryk] UX 2011-12-08 06:50:52 PST
Can you let me know when this reaches nightly? Thanks!
Comment 8 Patrick Walton (:pcwalton) 2011-12-08 21:33:43 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/c28beca4a896
Comment 9 u88484 2011-12-10 14:18:50 PST
This is probably the biggest annoyance I have since native UI landed.  It serves no purpose what so ever and make scrolling up and down pages suck badly because the axis lock also doesn't work well so pages scroll in a wavy way.
Comment 10 Patrick Walton (:pcwalton) 2011-12-10 14:42:02 PST
(In reply to Kurt Schultz (supernova_00) from comment #9)
> This is probably the biggest annoyance I have since native UI landed.  It
> serves no purpose what so ever and make scrolling up and down pages suck
> badly because the axis lock also doesn't work well so pages scroll in a wavy
> way.

This should hit nightly in a day or two -- tree closure has prevented it from making it in before, but it is on its way.
Comment 11 Ed Morley [:emorley] 2011-12-10 20:42:54 PST
https://hg.mozilla.org/mozilla-central/rev/c28beca4a896
Comment 12 Andreea Pod 2013-02-28 02:39:46 PST
Verified fixed on:
-build:  Firefox for Android 22.0a1 (2013-02-27)
-device: Samsung Galaxy Nexus
-OS: Android 4.2.2

Note You need to log in before you can comment on or make changes to this bug.