Last Comment Bug 705365 - Set the plugin hang timeout shorter than the Firefox hang timeout
: Set the plugin hang timeout shorter than the Firefox hang timeout
Status: RESOLVED FIXED
[qa?]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Benjamin Smedberg [:bsmedberg]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on: 722394
Blocks: hang-detector
  Show dependency treegraph
 
Reported: 2011-11-25 13:48 PST by Benjamin Smedberg [:bsmedberg]
Modified: 2012-03-05 16:38 PST (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Shorten plugin hang timeout to 25 secs, rev. 1 (1.33 KB, patch)
2011-11-25 13:50 PST, Benjamin Smedberg [:bsmedberg]
jmathies: review+
asa: feedback+
Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2011-11-25 13:48:06 PST
Currently the Firefox hang monitor (from bug 429592) is triggering for plugin hangs because the plugin hang timeout (45s) is longer than the Firefox hang timeout (30s). I propose shortening the plugin hang timeout to 25 seconds and see what kind of data we get.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-11-25 13:50:09 PST
Created attachment 576998 [details] [diff] [review]
Shorten plugin hang timeout to 25 secs, rev. 1
Comment 2 Asa Dotzler [:asa] 2011-11-25 16:28:18 PST
FWIW, I think this is a righteous change.
Comment 3 Benjamin Smedberg [:bsmedberg] 2011-11-25 19:52:34 PST
Landed https://hg.mozilla.org/mozilla-central/rev/6f079f13c06a with presumptive-r so that we can get proper feedback over the weekend without annoying users.
Comment 4 henryfhchan 2011-11-25 21:42:03 PST
The plugin hang was set to 45 seconds in Firefox 3.6.6 because of on old computers some facebook games took more than 40 seconds to load and caused a number of crashes.

http://www.mozilla.org/en-US/firefox/3.6.6/releasenotes/

See bug 574905
Comment 5 Masatoshi Kimura [:emk] 2011-11-26 00:21:47 PST
Firefox hang timeout was not implemented at that point.
Comment 6 Benjamin Smedberg [:bsmedberg] 2011-11-26 06:30:43 PST
Asa and I are both well aware of the history of bug 574905, which is why I wrote "and see what kind of data we get". It is likely that the hang monitor and this timeout change will be backed out of beta and release channels for a few releases yet while we monitor the crash-stats data and figure out how to work around these issues.
Comment 7 Robert Kaiser 2011-11-26 08:56:22 PST
I fortunately caught this by reading pushlog, but could you notify the CrashKill team when tweaking those hang time parameters? As we look at numbers of hangs, there probably can be correlations with those changes, so we should know to be watching for that. Thanks.
Comment 8 Scoobidiver (away) 2011-11-27 14:46:50 PST
This bug has improved things, but that's still worse than before bug 429592 landed:
BuildID    Crashes
20111123:  754
20111124   2939 <-- Bug 429592
20111125   2915
20111126   1809 <-- Bug 705365
Comment 9 Sheila Mooney 2012-02-07 16:38:06 PST
Ben (or somebody else). I spoke to Asa about this. He has suggested that we back it out for now - put the timer back to 45s. He wants to do some user research targeted around assessing the right level of timeout. Also, the implication in comment #6 is that we weren't going to keep it in for beta and release. The hang detector was only on for a few days and this change just got left in.
Comment 10 Scoobidiver (away) 2012-02-09 09:50:25 PST
The hang ratio is 0.06% in 10.0 and 1.4% in 11.0b1!
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-05 16:38:37 PST
Is there anything QA can do to verify this fix?

Note You need to log in before you can comment on or make changes to this bug.