Tab key should move focus to the next field in a form

VERIFIED FIXED

Status

()

VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: dburckh, Assigned: alexp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HKB][VKB])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

Went to Amazon.com or Hotmail.com clicked on a field and hit the tab key on my Asus transformer dock.  Tried up/down/left/right, no response at all.


Actual results:

It appears Firefox inserted a literal "Tab" into the entry field.


Expected results:

It should have tabbed from the user name to the password field.
OS: Windows 7 → Android
Hardware: x86_64 → ARM

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

7 years ago
Changing the summary to describe the actual issue.
Arrow keys work inside the edit boxes, or switch between the options as they should. They are not supposed to move between the fields.
The issue is reproducible both on HKB's and VKB's with a Tab key (e.g. Hacker's Keyboard).
Assignee: nobody → alexp
Status: NEW → ASSIGNED
Summary: Navigation Keys Not Working Asus Transformer Dock → Tab key should move focus to the next field in a form
Whiteboard: [HKB][VKB]
(Assignee)

Comment 2

7 years ago
It's a regression - it worked before the pan/zoom layers were added.
Looks like our LayerView, which extends GLSurfaceView, does not get key-down events, its onKeyDown method (and the same one in GeckoInputConnection) does not get called, and that causes this issue.
(Assignee)

Comment 3

7 years ago
Created attachment 578028 [details] [diff] [review]
Fix

This seems to fix the bug. The onKeyPreIme() still gets called, and an explicit check for the Tab key there works.
Attachment #578028 - Flags: review?(blassey.bugs)
Attachment #578028 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 4

7 years ago
hg.mozilla.org/projects/birch/rev/5f197183f884
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

7 years ago
Retested bug with :
Mozilla/5.0 (Android; Linux arm7l; rv:11.0a1) Gecko/20111205 Firefox/11.0a1 Fennec/11.0a1

Focus is changed from a field to next field when tab key is used. (For Hotmail and Gmail pages, from username to password field.)

Verifying bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.