typos in htmlparser.properties

RESOLVED FIXED in mozilla11

Status

()

Core
HTML: Parser
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Mark Tyndall, Assigned: hsivonen)

Tracking

9 Branch
mozilla11
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox10 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
http://mxr.mozilla.org/mozilla-central/source/dom/locales/en-US/chrome/layout/htmlparser.properties#57

http://mxr.mozilla.org/mozilla-central/source/dom/locales/en-US/chrome/layout/htmlparser.properties#59

errSlashNotFollowedByGt=A slash was not immediate followed by “>”.
"immediate" should be "immediately"

errUnquotedAttributeStartLt should end with a "." (all the other strings do).

This is also on aurora (where I saw it, whilst localising).  You can fix this there without affecting the string freeze.
Component: Layout → HTML: Parser
OS: Windows 7 → All
QA Contact: layout → parser
Hardware: x86_64 → All
(Assignee)

Comment 1

6 years ago
Created attachment 577225 [details] [diff] [review]
Fix the typos
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Attachment #577225 - Flags: review?(bugs)

Updated

6 years ago
Attachment #577225 - Flags: review?(bugs) → review+
(Assignee)

Updated

6 years ago
Blocks: 482921
(Assignee)

Comment 2

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b4d7154db36
status-firefox10: --- → affected
Flags: in-testsuite-
Target Milestone: --- → mozilla11
https://hg.mozilla.org/mozilla-central/rev/7b4d7154db36
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
Comment on attachment 577225 [details] [diff] [review]
Fix the typos

(This comment has been posted on all the bugs mentioned in this comment, except bug 710142, so that the release drivers see it regardless of the order in which they process approval requests.)

The new View Source implementation landed before Firefox 10 moved to Aurora. Afterwards, a bunch of regressions were identified. Many of the regression fixes didn't land before Firefox 10 moved to Aurora but they have now been fixed on trunk except for bug 710142.

To avoid shipping with regressions, we either need to land all the regression fixes on Aurora for Firefox 10 (followed by a fix for bug 710142 in Beta if it doesn't make it before Dec 20th) or switch back to the old View Source implementation on Aurora. The new View Source implementation provides much better diagnostics for Web developers than the old View Source implementation.

So I'd like to ask the release drivers to either approve bug 535530, bug 699356, bug 699365, bug 700034, bug 700361, bug 703965, bug 704667 and bug 705473 plus bug 695640, which is a non-regression tweak, or to approve bug 710175 for reverting to the old View Source implementation for Firefox 10.
Attachment #577225 - Flags: approval-mozilla-aurora?

Comment 5

6 years ago
Comment on attachment 577225 [details] [diff] [review]
Fix the typos

[triage comment]
We decided to back out the new view source parser (bug 710175) rather than take this fixup for Firefox 10.

Denying for Aurora.
Attachment #577225 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
(Assignee)

Comment 6

6 years ago
Firefox 10 no longer affected due to bug 710175 landing. (Not affected in the sense that the UI string newer shows up even though the property file is there.)
status-firefox10: affected → unaffected
You need to log in before you can comment on or make changes to this bug.