Last Comment Bug 705580 - No Animation Of WunderMap Interactive Radar on Nightly
: No Animation Of WunderMap Interactive Radar on Nightly
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: mozilla11
Assigned To: Matt Woodrow (:mattwoodrow) (PTO until 27 June)
:
Mentors:
http://www.wunderground.com/wundermap...
Depends on:
Blocks: 695610
  Show dependency treegraph
 
Reported: 2011-11-27 17:47 PST by WildcatRay
Modified: 2012-01-09 11:25 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Remove the cached ImageContainer when the current frame changes. (2.35 KB, patch)
2011-11-27 20:26 PST, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
no flags Details | Diff | Review
Remove the cached ImageContainer when the current frame changes. v2 (1.59 KB, patch)
2011-11-27 20:29 PST, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
joe: review+
Details | Diff | Review
Add animated image test that uses an ImageLayer (2.99 KB, patch)
2011-11-28 20:11 PST, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
joe: review+
Details | Diff | Review

Description WildcatRay 2011-11-27 17:47:52 PST
On WunderMap Interactive Radar of wunderground.com, the map does not animate (goes into motion). It does work in Aurora builds and Firefox. (Regression confirmed in new profile on Nightly.)

To start animate, click on the blue button just to the right of "Animate" to the right of the map.
Comment 1 Alice0775 White 2011-11-27 18:39:36 PST
Regression window(m-i)
works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a126c53a037e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111108 Firefox/11.0a1 ID:20111108160609
Fails(skip middle frames):
http://hg.mozilla.org/integration/mozilla-inbound/rev/20c6e85f8a59
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111108 Firefox/11.0a1 ID:20111108191531
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a126c53a037e&tochange=20c6e85f8a59
Triggered by:
20c6e85f8a59	Matt Woodrow — Bug 695610 - Move ImageContainer caching into imgIContainer. r=joe
Comment 2 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-11-27 20:26:01 PST
Created attachment 577188 [details] [diff] [review]
Remove the cached ImageContainer when the current frame changes.

Since mImageContainer is a cache of FRAME_CURRENT, we need to reset it whenever this changes.

It would be nice to move the cache onto the imgFrame itself instead of the container, but this would be a memory usage regression currently.
Comment 3 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-11-27 20:29:43 PST
Created attachment 577189 [details] [diff] [review]
Remove the cached ImageContainer when the current frame changes. v2

Removed unrelated change included by accident.
Comment 4 Peter van der Woude [:Peter6] 2011-11-28 02:38:51 PST
http://www.meteox.com/h.aspx?r=&jaar=-3&soort=satradar doesn't animate either, same problem ?
Comment 5 Jim Jeffery not reading bug-mail 1/2/11 2011-11-28 08:49:14 PST
It was noted in the mozillazine forums that changing the opacity slider, does not matter if you change it up or down, the animation starts up on the wunderground radar test url. 

Didn't know if that fact changed anything in the thinking for the fix as adapted and waiting review.
Comment 6 Joe Drew (not getting mail) 2011-11-28 12:58:31 PST
Comment on attachment 577189 [details] [diff] [review]
Remove the cached ImageContainer when the current frame changes. v2

Review of attachment 577189 [details] [diff] [review]:
-----------------------------------------------------------------

Argh. Can we add tests for this?
Comment 7 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-11-28 20:11:29 PST
Created attachment 577471 [details] [diff] [review]
Add animated image test that uses an ImageLayer

Exactly the same as test_animation.html, except that it uses an inconsequential opacity to force the image to have an ImageLayer created.
Comment 8 Joe Drew (not getting mail) 2011-11-30 10:41:25 PST
Comment on attachment 577471 [details] [diff] [review]
Add animated image test that uses an ImageLayer

Review of attachment 577471 [details] [diff] [review]:
-----------------------------------------------------------------

As long as this passes try (I presume 0.9999 * 0x2aff00 rounds to 2aff00 on all our platforms) all's well.
Comment 11 Peter van der Woude [:Peter6] 2011-12-06 08:51:48 PST
Mozilla/5.0 (Windows NT 5.1; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 ID:20111206031117
VERIFIED FIXED for both urls (wunderground/meteox)

Note You need to log in before you can comment on or make changes to this bug.