mozilla-inbound build is broken after Bug 685395 part 3

RESOLVED FIXED

Status

()

Core
Widget: Gtk
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ojab, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 577184 [details]
mozconfig

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111127 Firefox/11.0a1
Build ID: 20111127044844

Steps to reproduce:

Last revision that builds fine:
changeset:   80850:a7c68967a6ed
user:        Masayuki Nakano <masayuki@d-toybox.com>
date:        Sun Nov 27 20:51:52 2011 +0900
summary:     Bug 685395 part.2 Move IMEContext to mozilla::widget::InputContext r=roc

You can found my mozconfig in the attached file.

linux x86_64, gcc-4.6.2, gtk+-2.24.8.


Actual results:

make[8]: Entering directory `/home/ojab/opt/xulrunner/widget/src/gtk2'
c++ -o nsWindow.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /sources/mozilla-inbound/config/gcc_hidden.h -DNATIVE_THEME_SUPPORT -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DOSTYPE=\"Linux3.1\" -DOSARCH=Linux -DEXCLUDE_SKIA_DEPENDENCIES  -DOS_LINUX=1 -DOS_POSIX=1  -DCAIRO_GFX -I/sources/mozilla-inbound/ipc/chromium/src -I/sources/mozilla-inbound/ipc/glue -I../../../ipc/ipdl/_ipdlheaders  -I/sources/mozilla-inbound/widget/src/gtk2 -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr4 -I/usr/include/nss     -I/sources/mozilla-inbound/widget/src/gtk2/../xpwidgets -I/sources/mozilla-inbound/widget/src/gtk2/../shared -I/sources/mozilla-inbound/layout/generic -I/sources/mozilla-inbound/layout/xul/base/src -I/sources/mozilla-inbound/other-licenses/atk-1.0  -I/sources/mozilla-inbound/widget/src/gtk2/../shared/x11  -fPIC -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -fno-exceptions -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15   -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15   -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/gtk-unix-print-2.0      -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/nsWindow.pp /sources/mozilla-inbound/widget/src/gtk2/nsWindow.cpp
/sources/mozilla-inbound/widget/src/gtk2/nsWindow.cpp:6589:1: error: ‘InputContext’ does not name a type
make[8]: *** [nsWindow.o] Error 1
make[8]: Leaving directory `/home/ojab/opt/xulrunner/widget/src/gtk2'
(Reporter)

Updated

6 years ago
Blocks: 685395
Component: General → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 1

6 years ago
Created attachment 577185 [details] [diff] [review]
patch that works for me
(Reporter)

Updated

6 years ago
Attachment #577185 - Flags: review?
Comment on attachment 577185 [details] [diff] [review]
patch that works for me

Please use nsIWidget::InputContext. With the change, r=me.

Thanks.
Attachment #577185 - Flags: review? → review+
(Reporter)

Comment 3

6 years ago
Created attachment 577195 [details] [diff] [review]
Use nsIWidget::InputContext
Attachment #577185 - Attachment is obsolete: true
Attachment #577195 - Flags: review+
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
Comment on attachment 577185 [details] [diff] [review]
patch that works for me

Er, wait. We should use same code for other platforms too. I'll attach a followup patch.
Attachment #577185 - Flags: review+
Keywords: checkin-needed
Attachment #577195 - Flags: review+
testing on try:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=e5451c6731e0
Created attachment 577205 [details] [diff] [review]
Additional patch
Attachment #577205 - Flags: review?(roc)
Comment on attachment 577205 [details] [diff] [review]
Additional patch

ojab:

Would you test this patch? (After your patch applied)

nsGtkIMModule might break on your environment.
Attachment #577205 - Flags: feedback?(ojab)
(Reporter)

Comment 8

6 years ago
Builds/works fine (don't know if and how I should set feedback+).
Attachment #577205 - Flags: review?(roc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6cf9f0eed660

Wow, during sleeping, this has been already fixed in bug 685395.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Attachment #577205 - Flags: feedback?(ojab)
You need to log in before you can comment on or make changes to this bug.