Last Comment Bug 705602 - Use mallocSizeOf in prefixset memory reporter
: Use mallocSizeOf in prefixset memory reporter
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Nicholas Nethercote [:njn] (on vacation until July 11)
:
Mentors:
Depends on:
Blocks: 707865
  Show dependency treegraph
 
Reported: 2011-11-27 21:37 PST by Nicholas Nethercote [:njn] (on vacation until July 11)
Modified: 2014-05-27 12:25 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.26 KB, patch)
2011-11-27 21:37 PST, Nicholas Nethercote [:njn] (on vacation until July 11)
gpascutto: review+
Details | Diff | Review

Description Nicholas Nethercote [:njn] (on vacation until July 11) 2011-11-27 21:37:22 PST
Created attachment 577193 [details] [diff] [review]
patch

I'm converting existing memory reporters to use mallocSizeOf.  See https://wiki.mozilla.org/Memory_Reporting for details about why I'm doing this.

This patch changes the "prefixset" memory reporter accordingly.  As part of this change, I removed nsUrlClassifierPrefixSet::SizeOfIncludingThis from the IDL, because there's no need for SizeOf-style functions to be exposed via IDL;  no other such functions are exposed in this way.  That change simplifies it significantly.
Comment 1 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-12-08 14:01:54 PST
Gian-Carlo, can you do this review soon?  It's a very small patch and it's blocking several pieces of my memory reporter work.  Thanks!
Comment 2 Gian-Carlo Pascutto [:gcp] 2011-12-08 23:22:10 PST
Comment on attachment 577193 [details] [diff] [review]
patch

You changed the UUID without updating everything. You'll need to update toolkit/components/build/nsToolkitCompsCID.h as well or things are going to break.

r+ if that is fixed.
Comment 3 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-12-15 16:34:10 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/03af7a7c3dc3

Note You need to log in before you can comment on or make changes to this bug.