Inspector panels should stay open across reloads

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
P2
normal
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: harth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [check-if-fixed-because-toolbox])

(Reporter)

Description

6 years ago
From a webdev in IRC:

13:04 potch: I like that firebug stays open when I reload the page, and the fact I have to reinvoke all the inspectors is very visually disruptive

The inspector disappears if you reload the page. It seems most likely that you'd want it to come back. Ideally remembering which element it was inspecting.

Updated

6 years ago
Priority: -- → P2

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696755

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 2

6 years ago
I have one problem like this issue.

OS ArchLinux 
firefox 12.0-2
(also I have installed Firebug 1.9.2)

Here is the steps for repeat:
1. Inspect some element.
2. Do not unselect current element. Inspect some element again. (On this step I have two selected elements)
3. Now, use the ESC key. Currently the last element is unselected and first selected element still selected. Reloading the page wasn't helps.

Is there need the new ticket?

Comment 3

6 years ago
(In reply to Alexander from comment #2)
> I have one problem like this issue.
> 
> OS ArchLinux 
> firefox 12.0-2
> (also I have installed Firebug 1.9.2)
> 
> Here is the steps for repeat:
> 1. Inspect some element.
> 2. Do not unselect current element. Inspect some element again. (On this
> step I have two selected elements)
> 3. Now, use the ESC key. Currently the last element is unselected and first
> selected element still selected. Reloading the page wasn't helps.
> 
> Is there need the new ticket?

Yes please. Especially if you can reproduce easily.

Comment 4

6 years ago
To reselect the node, we need a way to identify it across reloads (bug 701419).
Depends on: 701419

Comment 5

6 years ago
(In reply to Paul Rouget [:paul] from comment #3)
> (In reply to Alexander from comment #2)
> > I have one problem like this issue.
> > 
> > OS ArchLinux 
> > firefox 12.0-2
> > (also I have installed Firebug 1.9.2)
> > 
> > Here is the steps for repeat:
> > 1. Inspect some element.
> > 2. Do not unselect current element. Inspect some element again. (On this
> > step I have two selected elements)
> > 3. Now, use the ESC key. Currently the last element is unselected and first
> > selected element still selected. Reloading the page wasn't helps.
> > 
> > Is there need the new ticket?
> 
> Yes please. Especially if you can reproduce easily.

Done. Ticket 759128. Also I was added a video to view how to reproduce the bug.

Updated

5 years ago
Blocks: 782593

Updated

5 years ago
Whiteboard: [check-if-fixed-because-toolbox]

Comment 6

5 years ago
Fixed because Toolbox.

Bug triage, filter on PINKISBEAUTIFUL
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.