Note: There are a few cases of duplicates in user autocompletion which are being worked on.

"ASSERTION: horizontal damage extends outside table"

RESOLVED FIXED in mozilla11

Status

()

Core
Layout: Tables
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: Bernd)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla11
x86_64
Mac OS X
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(5 attachments, 1 obsolete attachment)

193 bytes, text/html
Details
2.98 KB, text/plain
Details
219 bytes, text/html
Details
24.82 KB, text/plain
Details
2.23 KB, patch
Mats Palmgren (vacation - back in August)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
Created attachment 577503 [details]
testcase

###!!! ASSERTION: horizontal damage extends outside table: '(aValue).XMost() <= GetColCount()', file layout/tables/nsTableFrame.cpp, line 3810

This assertion was added in bug 460637.
(Reporter)

Comment 1

6 years ago
Created attachment 577504 [details]
stack trace
(Reporter)

Comment 2

6 years ago
Created attachment 577883 [details]
testcase 2 (crashes Firefox when loaded)
(Reporter)

Comment 3

6 years ago
Created attachment 577885 [details]
stack traces
(Reporter)

Updated

6 years ago
Crash Signature: [@ nsTableFrame::CalcBCBorders]
(Reporter)

Comment 4

6 years ago
Assertions from testcase 2:

###!!! ASSERTION: horizontal damage extends outside table: '(aValue).XMost() <= GetColCount()', file layout/tables/nsTableFrame.cpp, line 3810

###!!! ASSERTION: dead cells should not require new columns: 'aCellFrame', file layout/tables/nsCellMap.cpp, line 1517

###!!! ASSERTION: invalid col index: 'Error', file layout/tables/nsTableFrame.cpp, line 436

###!!! ASSERTION: CellIterator program error: 'false', file layout/tables/nsTableFrame.cpp, line 4216

###!!! ASSERTION: invalid col index: 'Error', file layout/tables/nsTableFrame.cpp, line 436

###!!! ASSERTION: null mCurrentColFrame: 'Error', file layout/tables/nsTableFrame.cpp, line 5380
(Assignee)

Updated

6 years ago
Assignee: nobody → bernd_mozilla
(Assignee)

Comment 5

6 years ago
Created attachment 578301 [details] [diff] [review]
patch

https://tbpl.mozilla.org/?tree=Try&rev=97ad9543209b
Attachment #578301 - Flags: review?(matspal)
(Assignee)

Comment 6

6 years ago
Created attachment 578303 [details] [diff] [review]
patch
Attachment #578301 - Attachment is obsolete: true
Attachment #578301 - Flags: review?(matspal)
Attachment #578303 - Flags: review?(matspal)
Comment on attachment 578303 [details] [diff] [review]
patch

r=mats
Attachment #578303 - Flags: review?(matspal) → review+
(Assignee)

Comment 8

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8555cf2ffac8
https://hg.mozilla.org/mozilla-central/rev/8555cf2ffac8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
(Assignee)

Updated

6 years ago
Flags: in-testsuite+

Updated

6 years ago
Blocks: 706779

Updated

6 years ago
No longer blocks: 706779
Duplicate of this bug: 706779
You need to log in before you can comment on or make changes to this bug.