Last Comment Bug 706079 - ignore aria-activedescendant referent having no ARIA role
: ignore aria-activedescendant referent having no ARIA role
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: alexander :surkov
:
Mentors:
Depends on:
Blocks: aria a11yperf
  Show dependency treegraph
 
Reported: 2011-11-29 05:45 PST by alexander :surkov
Modified: 2012-01-21 03:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.41 KB, patch)
2011-11-29 05:45 PST, alexander :surkov
dbolter: review+
Details | Diff | Splinter Review

Description alexander :surkov 2011-11-29 05:45:29 PST
Created attachment 577572 [details] [diff] [review]
patch

That should be expensive to check aria-activedescendant parent for any element having ID. We ignore aria-activedencendant in some cases for example we do that for focusable state calculation. I think we should take this as a rule to ignore aria-activedescendant referents having no ARIA role. It doesn't make sense to manage HTML controls having no ARIA role by aria-activedescendant because they should be managed by DOM focus. And it doesn't make sense to allow aria-activedensendant pointing to elements having no semantics. So I don't see a usecase for that and thus let's save some time by ignoring such elements.
Comment 1 David Bolter [:davidb] ***PTO until 29th*** 2011-11-29 12:00:54 PST
I need to better understand the purpose of this change. How did this bug come about? Is "it doesn't make sense to allow aria-activedensendant pointing to elements having no semantics" specifically talking about semantics as in ARIA semantics? html::TD has implicit semantics for example.
Comment 2 alexander :surkov 2011-11-29 19:44:14 PST
(In reply to David Bolter [:davidb] from comment #1)
> I need to better understand the purpose of this change. How did this bug
> come about? 

cleaning up aria-activedescendant implementation

> Is "it doesn't make sense to allow aria-activedensendant
> pointing to elements having no semantics" specifically talking about
> semantics as in ARIA semantics? html::TD has implicit semantics for example.

I didn't think about html:td when I said that, so maybe 'focusable semantics'.
Comment 4 David Bolter [:davidb] ***PTO until 29th*** 2011-11-30 08:30:23 PST
Comment on attachment 577572 [details] [diff] [review]
patch

Review of attachment 577572 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. I hope the role requirement doesn't break anyone.

::: accessible/src/base/nsAccessibilityService.cpp
@@ -926,1 @@
>  }

This removal seems hypothetically dangerous, but I think I'm okay with it.
Comment 5 alexander :surkov 2011-12-07 09:25:27 PST
Marco, as you asked the try server build is here http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/surkov.alexander@gmail.com-7476b968a388/
Comment 6 Marco Zehe (:MarcoZ) 2011-12-08 02:13:16 PST
All's well with the try-build. I think this is safe to land.
Comment 7 alexander :surkov 2012-01-20 07:20:48 PST
inbound land https://hg.mozilla.org/integration/mozilla-inbound/rev/0ed3beaf8247
Comment 8 alexander :surkov 2012-01-21 03:00:36 PST
landed https://hg.mozilla.org/mozilla-central/rev/0ed3beaf8247

Note You need to log in before you can comment on or make changes to this bug.