Last Comment Bug 706092 - Inspector : can't close inspector pane
: Inspector : can't close inspector pane
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: Trunk
: x86 Mac OS X
-- normal (vote)
: Firefox 17
Assigned To: Rob Campbell [:rc] (:robcee)
:
: Gabriel Luong [:gl][1 biz day review guarantee] (ΦωΦ)
Mentors:
Depends on: 761251
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 06:22 PST by bobi
Modified: 2013-01-12 13:47 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
treepanel fix (2.48 KB, patch)
2012-08-02 13:42 PDT, Rob Campbell [:rc] (:robcee)
dcamp: review+
Details | Diff | Splinter Review

Description User image bobi 2011-11-29 06:22:14 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111127 Firefox/10.0a2
Build ID: 20111127042022

Steps to reproduce:

Steps 

1. I inspected some elements and then  settled on one
2. Opended the style pane and changed some value (color)
3. Closed the style pane. OK
4. Try to close the inspector (click on left cross). Not working
5. Tried to reload page. A bar appears on top, telling there was some mod. do i want to reload still ? 
6. Clicked on "leave page" but after reload the inspector is still open. 
7. Tried to click on each element in the breadcrumb but nothing is working

I've not tried to reproduce...
 



Expected results:

The inspector should always react to actions.
Comment 1 User image Rob Campbell [:rc] (:robcee) 2012-01-17 09:42:43 PST
Can we get some testing on this? Looks like this occurred in Fx10.0a2 which should now be in Beta.
Comment 2 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-21 11:35:27 PDT
I'm unable to reproduce this in the same build. 

@bobi, can you check Error Console to see if anything comes up when failing to close the Inspect bar?
Comment 3 User image Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-02 11:27:14 PDT
From Kevin:
> I think there's a bug open on this, but I wanted to pass along that I've seen a
> number of reports on input.mozilla.com that people are having trouble with the
> inspector not closing (it sounds like this is largely on Aurora).
Comment 4 User image Rob Campbell [:rc] (:robcee) 2012-08-02 12:44:32 PDT
I found some steps to reproduce the Uncloseable Inspector.

1. Go to a webpage (this one will do).
2. Open the Inspector and lock a node.
3. Open the Markup panel (if necessary).
4. Double click an attribute value to open the editor
5. Close the Markup panel (without closing the popup text editor).
6. Click the close button on the inspector toolbar.

Expected Results:
Inspector should close.

Actual Result:
Inspector stays open. worse, appears across all tabs.

Error message on error console:

Timestamp: 2012-08-02 3:39:13 PM
Error: TypeError: this.treeBrowserDocument is undefined
Source File: resource:///modules/TreePanel.jsm
Line: 522
Comment 5 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-02 13:14:39 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #4)
> I found some steps to reproduce the Uncloseable Inspector.

Thanks Rob. Can you confirm which Firefox version you used with these steps?
Comment 6 User image Rob Campbell [:rc] (:robcee) 2012-08-02 13:25:21 PDT
today's nightly.

[16:25:15.647] "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0"
Comment 7 User image Rob Campbell [:rc] (:robcee) 2012-08-02 13:42:57 PDT
Created attachment 648468 [details] [diff] [review]
treepanel fix

fix. Tested with and without fix applied. Unittest will timeout and fail if this fix isn't installed.
Comment 8 User image Panos Astithas [:past] 2012-08-03 01:55:14 PDT
https://hg.mozilla.org/integration/fx-team/rev/98216d5724de
Comment 9 User image Rob Campbell [:rc] (:robcee) 2012-08-03 14:24:42 PDT
https://hg.mozilla.org/mozilla-central/rev/98216d5724de
Comment 10 User image n308094 2012-09-15 06:59:56 PDT
This has NOT been resolved. I accidentally opened the inspector and can't close it no matter what. This is ridiculous.
Comment 11 User image n308094 2012-09-15 07:06:24 PDT
Using Firefox 15 on Windows XP and have this problem. It needs fixing on the Windows version of Firefox. I accidentally opened it and can't close it.
Comment 12 User image pie.or.paj 2013-01-12 10:17:39 PST
Using Firefox 18 and Ubuntu 12.10 I still have this bug.
Comment 13 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-12 10:35:31 PST
(In reply to pie.or.paj from comment #12)
> Using Firefox 18 and Ubuntu 12.10 I still have this bug.

I believe this bug was specifically filed for Mac OSX. Though it would seem that you are not alone in reporting this is happening on other platforms as well.

Rob Campell, can you please advise if we should reopen this bug or file a new bug to address this issue on other platforms.
Comment 14 User image Paul Rouget [:paul] 2013-01-12 13:47:14 PST
A lot of different things were causing this bug. We re-wrote the whole thing in Firefox 20. And it's fixed.

Note You need to log in before you can comment on or make changes to this bug.