libxul.so in android builds has executable stack

RESOLVED DUPLICATE of bug 671426

Status

RESOLVED DUPLICATE of bug 671426
7 years ago
9 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
# readelf -l obj-arm-linux-androideabi/dist/lib/libxul.so | grep STACK
  GNU_STACK      0x000000 0x00000000 0x00000000 0x00000 0x00000 RWE 0x4

The permissions should be RW instead of RWE. In practice, it's not a real issue, because the android linker doesn't support executable stack at all, but the new linker I'm writing for bug 683127 does reject libraries with executable stack (because it's safer to do so), which makes it reject libxul.so on android.

My wild guess is that we lack the necessary bits in some of the assembly files.
(Assignee)

Updated

7 years ago
Blocks: 683127

Comment 1

7 years ago
Marking a dupe of 671426, let me know if you disagree :)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671426

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.