Last Comment Bug 706192 - ua.css specifies invalid value 'none' for 'clip' property
: ua.css specifies invalid value 'none' for 'clip' property
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on: 702146
Blocks: 685779
  Show dependency treegraph
 
Reported: 2011-11-29 11:27 PST by Daniel Holbert [:dholbert]
Modified: 2012-01-30 05:26 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (included in patch on bug 702146) (988 bytes, patch)
2011-11-29 11:31 PST, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-11-29 11:27:35 PST
Just noticed this in my error console:
=====
Warning: Error in parsing value for 'clip'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 273
=====

This is from this line:
>276   clip:none !important;
http://mxr.mozilla.org/mozilla-central/source/layout/style/ua.css#276
which was added in bug 685779.

There is no 'none' value for clip -- the equivalent value (for no clipping) is 'auto':
  http://www.w3.org/TR/CSS21/visufx.html#propdef-clip
Comment 1 Daniel Holbert [:dholbert] 2011-11-29 11:29:06 PST
bug 685779 landed before the last migration (and is in aurora for Firefox 10), so we probably want to fix this on aurora after it's fixed on trunk.
Comment 2 Daniel Holbert [:dholbert] 2011-11-29 11:31:23 PST
Created attachment 577687 [details] [diff] [review]
fix (included in patch on bug 702146)
Comment 3 PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-29 11:57:54 PST
I included this fix in my patch for bug 702146, I'm just waiting for review on it. I'm not sure if we need to take this fix on Aurora/Firefox 10 or not... I've previously discussed it with Roc, and we thought we'd let the patch in bug 702146 (along with this fix) ship in Firefox 11. You're welcome to try to convince me otherwise! :)
Comment 4 Daniel Holbert [:dholbert] 2011-11-29 12:21:03 PST
(In reply to Chris Pearce (:cpearce) (Mozilla Corporation) from comment #3)
> I've previously discussed it with Roc, and we thought we'd let the
> patch in bug 702146 (along with this fix) ship in Firefox 11. You're welcome
> to try to convince me otherwise! :)

Ah -- I was assuming there might be security and/or rendering-potentially-busted implications, but it sounds like it's not too bad.

Marking this as depends-on bug 702146 for now (to be updated to FIXED by that bug when it lands).  Feel free to dupe if that's cleaner.
Comment 5 Daniel Holbert [:dholbert] 2011-11-30 10:11:29 PST
Looks like bug 702146's patch has now landed, so this is FIXED by that bug.

Note You need to log in before you can comment on or make changes to this bug.