Last Comment Bug 706283 - window.mozRequestAnimationFrame(null) crashes
: window.mozRequestAnimationFrame(null) crashes
Status: RESOLVED FIXED
: crash, regression, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla11
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Andrew Overholt [:overholt]
Mentors:
: 706774 (view as bug list)
Depends on:
Blocks: 326633 704171
  Show dependency treegraph
 
Reported: 2011-11-29 15:00 PST by Jesse Ruderman
Modified: 2012-01-09 11:29 PST (History)
10 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
testcase (crashes Firefox when loaded) (76 bytes, text/html)
2011-11-29 15:00 PST, Jesse Ruderman
no flags Details
stack trace (2.12 KB, text/plain)
2011-11-29 15:00 PST, Jesse Ruderman
no flags Details
Handle null passed to requestAnimationFrame gracefully. (1.52 KB, patch)
2011-11-30 14:22 PST, Boris Zbarsky [:bz] (still a bit busy)
roc: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-11-29 15:00:30 PST
Created attachment 577761 [details]
testcase (crashes Firefox when loaded)

Regression from bug 704171?
Comment 1 Jesse Ruderman 2011-11-29 15:00:49 PST
Created attachment 577762 [details]
stack trace
Comment 2 Jesse Ruderman 2011-11-30 14:02:17 PST
I think I hit this while zooming in on Google Maps (WebGL) bp-329ef1ab-2dd0-4456-811e-859ae2111130.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-11-30 14:14:55 PST
Yeah, sure looks like it.  Good thing I was in the middle of testing the patch.  ;)
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-11-30 14:22:03 PST
Created attachment 578083 [details] [diff] [review]
Handle null passed to requestAnimationFrame gracefully.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2011-12-01 11:16:35 PST
*** Bug 706774 has been marked as a duplicate of this bug. ***
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2011-12-01 11:30:22 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4827b51003b
Comment 7 Marco Bonardo [::mak] 2011-12-02 03:17:16 PST
https://hg.mozilla.org/mozilla-central/rev/b4827b51003b

Note You need to log in before you can comment on or make changes to this bug.