Firefox 10.0a2 Crash Report [@ je_free | js::gc::Arena::finalize<JSObject>(JSContext*, js::gc::AllocKind, unsigned int) ]

RESOLVED DUPLICATE of bug 698296

Status

()

--
critical
RESOLVED DUPLICATE of bug 698296
7 years ago
6 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
Noticed this Crash on the Top Changer Lists. Example Crash Report -> https://crash-stats.mozilla.com/report/index/85e181a8-95eb-4018-b420-cb3f52111129 and overview -> https://crash-stats.mozilla.com/report/list?range_value=3&range_unit=days&signature=je_free%20|%20js%3A%3Agc%3A%3AArena%3A%3Afinalize%3CJSObject%3E%28JSContext*%2C%20js%3A%3Agc%3A%3AAllocKind%2C%20unsigned%20int%29&version=Firefox%3A10.0a2

All Windows Crashes it seems.


Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozutils.dll 	je_free 	memory/jemalloc/jemalloc.c:6497
1 	mozjs.dll 	js::gc::Arena::finalize<JSObject> 	js/src/jsgc.cpp:302
2 	mozjs.dll 	js::gc::FinalizeTypedArenas<JSObject> 	js/src/jsgc.cpp:349
3 	mozjs.dll 	js::gc::FinalizeArenas 	js/src/jsgc.cpp:390
4 	mozjs.dll 	js::gc::ArenaLists::backgroundFinalize 	js/src/jsgc.cpp:1509
5 	mozjs.dll 	js::GCHelperThread::doSweep 	js/src/jsgc.cpp:2342
6 	mozjs.dll 	js::GCHelperThread::threadLoop 	js/src/jsgc.cpp:2224
7 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
8 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
9 	msvcr80.dll 	_callthreadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:348
10 	msvcr80.dll 	_threadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:326
11 	kernel32.dll 	BaseThreadStart

Comment 1

7 years ago
Dupe of bug 698296?

Comment 2

7 years ago
It's #115 top browser crasher in 10.0.2:

Here are correlations of the day:
  je_free | js::gc::Arena::finalize<JSString>(JSContext*, js::gc::AllocKind, unsigned int)|EXCEPTION_ACCESS_VIOLATION_READ (201 crashes)
     75% (150/201) vs.   8% (4361/56926) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
     30% (60/201) vs.   6% (3340/56926) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D} (Спутник @Mail.Ru)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 698296
You need to log in before you can comment on or make changes to this bug.