Last Comment Bug 706554 - Add nsRefPtrHashKey
: Add nsRefPtrHashKey
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on:
Blocks: 604039
  Show dependency treegraph
 
Reported: 2011-11-30 10:41 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-01-19 17:47 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add nsRefPtrHashKey (1.51 KB, patch)
2011-11-30 10:53 PST, Ted Mielczarek [:ted.mielczarek]
benjamin: review+
Details | Diff | Review

Description Ted Mielczarek [:ted.mielczarek] 2011-11-30 10:41:32 PST
I wound up needing this for my gamepad patches, since I'm hanging on to nsGlobalWindow* directly instead of using interfaces.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-11-30 10:53:34 PST
Created attachment 578014 [details] [diff] [review]
Add nsRefPtrHashKey

We don't seem to have comprehensive tests on the hashtable stuff, but I'd be happy to add tests for this to TestHashtables.cpp if you'd like.
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-11-30 11:08:52 PST
Comment on attachment 578014 [details] [diff] [review]
Add nsRefPtrHashKey

Could we just typedef nsRefPtrHashKey<nsISupports> nsISupportsHashKey? Probably doesn't matter though.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-11-30 11:09:51 PST
We'd lose comptr logging on hash keys then.  Whether or not people actually care about that, idk.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2012-01-19 09:27:02 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/043724be2771
Comment 5 Ed Morley [:emorley] 2012-01-19 17:47:20 PST
https://hg.mozilla.org/mozilla-central/rev/043724be2771

Note You need to log in before you can comment on or make changes to this bug.