Last Comment Bug 706558 - Remove SetEventCallback
: Remove SetEventCallback
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-30 10:48 PST by Michael Wu [:mwu]
Modified: 2011-12-25 11:05 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove SetEventCallback (2.15 KB, patch)
2011-11-30 10:50 PST, Michael Wu [:mwu]
roc: review+
Details | Diff | Splinter Review
Require the event callback to be defined (8.79 KB, patch)
2011-11-30 10:57 PST, Michael Wu [:mwu]
roc: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2011-11-30 10:48:32 PST

    
Comment 1 Michael Wu [:mwu] 2011-11-30 10:50:19 PST
Created attachment 578012 [details] [diff] [review]
Remove SetEventCallback

It doesn't look like anyone uses SetEventCallback
Comment 2 Michael Wu [:mwu] 2011-11-30 10:57:23 PST
Created attachment 578016 [details] [diff] [review]
Require the event callback to be defined

mEventCallback appears to always be set, so let's require it and simplify the code that calls it.
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-11-30 13:40:11 PST
Comment on attachment 578012 [details] [diff] [review]
Remove SetEventCallback

Review of attachment 578012 [details] [diff] [review]:
-----------------------------------------------------------------

rev nsIWidget IID
Comment 4 Michael Wu [:mwu] 2011-12-07 00:14:25 PST
2nd patch doesn't pass try.. apparently windows cares about windows without an event callback.
Comment 5 Michael Wu [:mwu] 2011-12-13 10:54:59 PST
Since we really want to remove code right now, I landed the first patch with a nsIWidget IID rev.

https://hg.mozilla.org/mozilla-central/rev/0723ae8c9416

I'll deal with the 2nd part in another bug once I get to it.
Comment 6 Josh Aas 2011-12-25 11:05:33 PST
This was added as part 1 of bug 90268, I'm going to have to add it back again shortly.

Note You need to log in before you can comment on or make changes to this bug.