"Cache-Control: no-store" on requests is not implemented

RESOLVED DUPLICATE of bug 428916

Status

()

RESOLVED DUPLICATE of bug 428916
7 years ago
3 years ago

People

(Reporter: bjarne, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 578240 [details] [diff] [review]
Test for no-store requests

According to Rfc2616 section 14.9.2 the "no-store" cache-directive can be applied to both request and response. We handle only the latter. Attached is a patch with a test. The patch also adds a test-case to an existing unit-test to make it more relevant.
For the reasons I explained in dev.tech.network, I am skeptical about taking this with no real use case.
(Reporter)

Comment 2

7 years ago
See also bug #428916

Comment 3

5 years ago
The bug is still not fixed, not even on Firefox 29 Nightly.
On Chrome setRequestHeader('Cache-Control', 'no-cache') would avoid the cache and retry new XMLHttpRequest.
this makes sense to me. honza, what do you think?
Flags: needinfo?(honzab.moz)
RFC 2616:

- Cache-control: no-store: "If sent in a request, a cache MUST NOT store any part of either this request or any response to it." [1]

  => it says nothing about revalidation, we only must prevent persisting the entry (i.e. set it memory-only)


- Cache-Control: no-cache: "The request includes a 'no-cache' cache-control directive" leads to "End-to-end reload" (=load from the origin server) [2]

  => yes, we don't implement this part


[1] http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.9.1
[2] http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.9.4
Flags: needinfo?(honzab.moz)

Comment 6

5 years ago
Requested header Cache-Control: no-store does not avoid cache.

Comment 7

5 years ago
(In reply to Honza Bambas (:mayhemer) from comment #5)
> RFC 2616:
> ...

Note that you really ought to look at <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p6-cache-25.html#cache-request-directive> (but it seems the answer is the same)

Comment 8

5 years ago
The problem is - nothing supported from Cache-Control sent by the user agent.
For example Cache-Control: "no-cache", Cache-Control: "max-age=0", Cache-Control: "max-age=0, must-revalidate" must avoid cache, but does not on Firefox.

Cache-Control explained in http://stackoverflow.com/questions/1046966/whats-the-difference-between-cache-control-max-age-0-and-no-cache
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428916
You need to log in before you can comment on or make changes to this bug.