Last Comment Bug 706822 - Delay when opening the AwesomeScreen and intermittent UI pauses when scrolling through listing of items
: Delay when opening the AwesomeScreen and intermittent UI pauses when scrollin...
Status: VERIFIED FIXED
: perf, regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-01 07:03 PST by Aaron Train [:aaronmt]
Modified: 2012-03-06 06:19 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (1.92 KB, patch)
2011-12-01 10:39 PST, Brad Lassey [:blassey] (use needinfo?)
dougt: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-01 07:03:51 PST
Opening the AwesomeBar:

I/ActivityManager(  110): Displayed org.mozilla.fennec/org.mozilla.gecko.AwesomeBar: 1s+56ms

Scrolling through list of all items:

E/CursorWindow(  793): not growing since there are already 28 row(s), max size 1048576
E/Cursor  (  793): Failed allocating 230918 bytes for blob at 31,9
D/Cursor  (  793): finish_program_and_get_row_count row 40
D/Cursor  (  793): skip_rows row 3
E/CursorWindow(  793): need to grow: mSize = 1048576, size = 230918, freeSpace() = 91148, numRows = 29
E/CursorWindow(  793): not growing since there are already 29 row(s), max size 1048576
E/Cursor  (  793): Failed allocating 230918 bytes for blob at 31,9
D/Cursor  (  793): finish_program_and_get_row_count row 40
D/Cursor  (  793): skip_rows row 2
E/CursorWindow(  793): need to grow: mSize = 1048576, size = 230918, freeSpace() = 3116, numRows = 30
E/CursorWindow(  793): not growing since there are already 30 row(s), max size 1048576
E/Cursor  (  793): Failed allocating 230918 bytes for blob at 31,9
D/Cursor  (  793): finish_program_and_get_row_count row 40
D/Cursor  (  793): skip_rows row 1
E/CursorWindow(  793): need to grow: mSize = 1048576, size = 30614, freeSpace() = 716, numRows = 30
E/CursorWindow(  793): not growing since there are already 30 row(s), max size 1048576
E/Cursor  (  793): Failed allocating 30614 bytes for blob at 30,9
D/Cursor  (  793): finish_program_and_get_row_count row 41
E/CursorWindow(  793): need to grow: mSize = 1048576, size = 1150, freeSpace() = 955, numRows = 31
E/CursorWindow(  793): not growing since there are already 31 row(s), max size 1048576
E/Cursor  (  793): Failed allocating 1150 bytes for blob at 30,8
D/Cursor  (  793): finish_program_and_get_row_count row 41

--
Samsung Nexus S (Android 2.3.6)
20111201040252
http://hg.mozilla.org/projects/birch/rev/d71c91775f9b
Comment 2 Lucas Rocha (:lucasr) 2011-12-01 07:53:21 PST
Blassey, maybe caused by one your of screenshot patches?
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-12-01 10:39:45 PST
Created attachment 578307 [details] [diff] [review]
patch
Comment 4 Sriram Ramasubramanian [:sriram] 2011-12-01 13:12:18 PST
As per the documentation, the data should be stored in onPause().

http://developer.android.com/reference/android/app/Activity.html

"Note that it is important to save persistent data in onPause() instead of onSaveInstanceState(Bundle) because the latter is not part of the lifecycle callbacks, so will not be called in every situation as described in its documentation."

Also, there is a big discussion in: http://stackoverflow.com/a/2909211/1052787

I think, we might need to save it in onStop(), to avoid the flags.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-02 19:25:36 PST
This already landed
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-01-09 10:18:40 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/a1a85e201c73
Comment 7 Catalin Suciu [:csuciu] 2012-03-06 06:19:46 PST
Cannot reproduce this on: 
Nightly 13.0a1(2012-03-05)
Device: Samsung Galaxy S2
OS: Android 2.3.4

Note You need to log in before you can comment on or make changes to this bug.