Last Comment Bug 706830 - pressing "back" doesn't return user to about:home
: pressing "back" doesn't return user to about:home
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-01 07:22 PST by Madhava Enros [:madhava]
Modified: 2016-07-29 14:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (1.31 KB, patch)
2011-12-01 08:10 PST, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
Details | Diff | Splinter Review

Description Madhava Enros [:madhava] 2011-12-01 07:22:08 PST
When I start on the start page (about:home), tap on a "top site", finish with that site, and then hit back, I expect to end up back on about:home. Instead, I exit the app.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 08:03:51 PST
This kinda works for me. When I go back the page is blank, because we are not sending the message to Java to display the page.

Madhava - Are you sure you did not open the page in a new tab?
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 08:10:36 PST
Created attachment 578270 [details] [diff] [review]
patch

This patch uses "pageshow" instead of "load" events. History session does not fire "load" when going back or forward if the page is in BFcache.
Comment 3 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-01 09:04:52 PST
I get comment 1 when I hit the back button as well with today's nightly.  20111201 on Thrive.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 12:13:52 PST
https://hg.mozilla.org/projects/birch/rev/ef20feca5819
Comment 5 Aaron Train [:aaronmt] 2011-12-02 07:12:37 PST
Samsung Galaxy SII (Android 2.3.4)
20111202040206
http://hg.mozilla.org/projects/birch/rev/e2a54aafac18

Note You need to log in before you can comment on or make changes to this bug.