Last Comment Bug 706997 - [IncrementalGC] "Assertion failure: static_cast<T *>(t)->arenaHeader()->allocatedDuringIncremental,"
: [IncrementalGC] "Assertion failure: static_cast<T *>(t)->arenaHeader()->alloc...
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks: jsfunfuzz IncrementalGC
  Show dependency treegraph
 
Reported: 2011-12-01 14:54 PST by Gary Kwong [:gkw] [:nth10sd]
Modified: 2011-12-08 11:54 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (4.48 KB, text/plain)
2011-12-01 14:54 PST, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description Gary Kwong [:gkw] [:nth10sd] 2011-12-01 14:54:32 PST
Created attachment 578410 [details]
stack

for (e in (function() {
  ArrayBuffer(662240797)
})()) {}
newGlobal("new-compartment")

asserts js debug shell on larch changeset 370cedaf963f without any CLI arguments at Assertion failure: static_cast<T *>(t)->arenaHeader()->allocatedDuringIncremental,
Comment 1 Bill McCloskey (:billm) 2011-12-06 17:04:31 PST
For some reason I can't reproduce this. I'm using the right changeset, and I have a 32-bit Linux build. I suspect the problem may be fixed by this commit:
  https://hg.mozilla.org/projects/larch/rev/517ef660fb04
Could you check, Gary?
Comment 2 Gary Kwong [:gkw] [:nth10sd] 2011-12-08 11:54:42 PST
(In reply to Bill McCloskey (:billm) from comment #1)
> For some reason I can't reproduce this. I'm using the right changeset, and I
> have a 32-bit Linux build. I suspect the problem may be fixed by this commit:
>   https://hg.mozilla.org/projects/larch/rev/517ef660fb04
> Could you check, Gary?

autoBisect shows this is probably related to the following changeset:

The first good revision is:
changeset:   81481:517ef660fb04
user:        Bill McCloskey
date:        Tue Dec 06 16:00:58 2011 -0800
summary:     [INCREMENTAL] Enable barriers when new compartment created during incremental GC

Yes, that's correct!

Note You need to log in before you can comment on or make changes to this bug.