Last Comment Bug 707037 - Revert the update check frequency increase
: Revert the update check frequency increase
Status: RESOLVED FIXED
[qa-]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 17
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on: 481815
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-01 16:56 PST by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2012-08-14 08:13 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+
fixed
+
fixed
+
fixed


Attachments
Patch (v1) (1.56 KB, patch)
2012-02-02 13:01 PST, :Ehsan Akhgari (busy, don't ask for review please)
netzen: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2011-12-01 16:56:37 PST
We need to revert the code bug 707020 adds after the testing of bug 481815 is finished.
Comment 1 Brian R. Bondy [:bbondy] 2012-01-23 21:13:39 PST
Although the testing is not finished, we can probably revert this.
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2012-02-02 13:01:58 PST
Created attachment 593950 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Regression caused by (bug #): No regression, it's just something that we wanted on nightly but not on Aurora.
User impact if declined: Updates checked for more than necessary.
Testing completed (on m-c, etc.): This reverts us to the situation we were in before bug 702020.
Risk to taking this patch (and alternatives if risky): None.
String changes made by this patch: None.
Comment 3 Brian R. Bondy [:bbondy] 2012-02-02 15:37:13 PST
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

Review of attachment 593950 [details] [diff] [review]:
-----------------------------------------------------------------

This reverts it back to the correct old values for Aurora. Looks good.
Comment 4 Brian R. Bondy [:bbondy] 2012-02-02 16:18:12 PST
Sorry I should say:
This reverts it back to the correct old values for Nightly on the Aurora branch. Looks good.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-02-02 17:54:40 PST
Alex, can we take this on Aurora sooner rather than later please?  Thanks!  :-)
Comment 6 Alex Keybl [:akeybl] 2012-02-05 13:58:13 PST
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

[Triage Comment]
Minor interval change - low risk. Approved for Aurora.
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-02-06 13:33:24 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/111665833e7d
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-12 16:58:59 PDT
Ehsan: can we close this bug now?
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-23 13:04:21 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #8)
> Ehsan: can we close this bug now?

No, I've missed this on Aurora 13, which means that this will be on Beta13 tomorrow.  We need to take the patch on Aurora and Beta again tomorrow, but I'd like to hold off on landing this on central until the work in bug 307181 is finished.
Comment 10 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-23 13:04:49 PDT
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Regression caused by (bug #): No regression, it's just something that we wanted on nightly but not on Aurora.
User impact if declined: Updates checked for more than necessary.
Testing completed (on m-c, etc.): This reverts us to the situation we were in before bug 702020.
Risk to taking this patch (and alternatives if risky): None.
String changes made by this patch: None.
Comment 11 Alex Keybl [:akeybl] 2012-04-23 14:47:29 PDT
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

[Triage Comment]
Approving for Aurora 13 since we may still be able to land this before tomorrow's merge. Feel free to carry over to Beta 13 after the uplift.
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-23 14:56:05 PDT
(In reply to Alex Keybl [:akeybl] from comment #11)
> Comment on attachment 593950 [details] [diff] [review]
> Patch (v1)
> 
> [Triage Comment]
> Approving for Aurora 13 since we may still be able to land this before
> tomorrow's merge. Feel free to carry over to Beta 13 after the uplift.

Sorry if I was vague.  I do not want this on central, which is why I asked for approval on Aurora.  I'll land this on Aurora right now, and will re-request Aurora approval once again after the merge.
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-23 14:57:54 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/2e0d201168b3
Comment 14 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-24 14:51:24 PDT
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

Requesting approval for the new Aurora.
Comment 15 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-25 12:20:46 PDT
Comment on attachment 593950 [details] [diff] [review]
Patch (v1)

[Triage comment]
approved for the new aurora.
Comment 16 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-25 12:54:23 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/9a9581a8a539
Comment 17 Brian R. Bondy [:bbondy] 2012-05-31 07:19:28 PDT
Do we want to do anything here before June 5th?
Comment 18 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-31 08:19:26 PDT
We need to land this on Aurora after the uplift.  On central, I'd still like to keep this maybe for a couple of more weeks.
Comment 19 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-04 14:50:12 PDT
Ported to the new aurora as well: http://hg.mozilla.org/releases/mozilla-aurora/rev/898a1bd48058
Comment 20 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-16 16:39:30 PDT
Landed for Firefox 16 on Aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/8386a8f7289a

Also, time to stop this on Nightly as well:

https://hg.mozilla.org/integration/mozilla-inbound/rev/b4028e63e58b
Comment 21 Ed Morley [:emorley] 2012-07-17 02:08:53 PDT
https://hg.mozilla.org/mozilla-central/rev/b4028e63e58b

Note You need to log in before you can comment on or make changes to this bug.