If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox Crash @ js::mjit::EnterMethodJIT

RESOLVED DUPLICATE of bug 595351

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 595351
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

9 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
Seen while looking at 9.0b3 crash stats. This is the #4 top browser crash in B3 but did not have a bug associated with it. https://crash-stats.mozilla.com/report/list?signature=js::mjit::EnterMethodJIT%28JSContext*,%20js::StackFrame*,%20void*,%20JS::Value*,%20bool%29 to the reports which are all Windows. Crash currently happens on Trunk, Aurora and Beta.

Beta 3 seems to show a higher percentage of crashes according to the signature summary.

No correlations showing but I will try to dig some up manually

https://crash-stats.mozilla.com/report/index/2b50936d-98a7-4ce9-bed9-f10c32111201

Frame 	Module 	Signature [Expand] 	Source
0 		@0x8441a9b 	
1 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:884
2 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:962
3 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:611
4 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:678
5 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:167
6 	mozjs.dll 	array_extra 	js/src/jsarray.cpp:3238
7 	mozjs.dll 	js::NewNativeClassInstance 	js/src/jsobjinlines.h:1295
8 	mozjs.dll 	mozjs.dll@0x1d807f 	
9 	mozjs.dll 	array_forEach 	js/src/jsarray.cpp:3299
10 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:884
11 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:962
12 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:611
13 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:678
14 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:710
15 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5039
16 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1660
17 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:585
18 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
19 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
20 	xul.dll 	nsBrowserStatusFilter::OnLocationChange 	toolkit/components/statusfilter/nsBrowserStatusFilter.cpp:231
21 	xul.dll 	nsDocLoader::FireOnLocationChange 	uriloader/base/nsDocLoader.cpp:1421
22 	xul.dll 	nsDocShell::FireDummyOnLocationChange 	docshell/base/nsDocShell.h:275
23 	xul.dll 	nsDocShell::AddState 	docshell/base/nsDocShell.cpp:9872
24 	xul.dll 	nsHistory::ReplaceState 	dom/base/nsHistory.cpp:341
25 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
26 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1629
27 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:660
28 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4036
29 	mozjs.dll 	js::types::TypeMonitorCall 	js/src/jsinferinlines.h:330
30 	mozjs.dll 	UncachedInlineCall 	js/src/methodjit/InvokeHelpers.cpp:393
31 	mozjs.dll 	js::mjit::stubs::UncachedCallHelper 	js/src/methodjit/InvokeHelpers.cpp:480
32 	mozjs.dll 	CallCompiler::update 	js/src/methodjit/MonoIC.cpp:1088
33 	mozjs.dll 	js::mjit::ic::Call 	js/src/methodjit/MonoIC.cpp:1148
34 	mozjs.dll 	js::ContextStack::currentScript 	js/src/vm/Stack-inl.h:647
35 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:884
36 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:962
37 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4075
38 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:614
39 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:678
40 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:710
41 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5039
42 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1929
43 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:211
44 	xul.dll 	nsCxPusher::RePush 	content/base/src/nsContentUtils.cpp:2598
45 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:778
46 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:344
47 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:672
48 	xul.dll 	nsScriptElement::ScriptEvaluated 	
49 	xul.dll 	nsScriptLoader::FireScriptEvaluated 	content/base/src/nsScriptLoader.cpp:844
50 	xul.dll 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:811
51 	xul.dll 	nsScriptLoader::ProcessPendingRequests 	
52 	xul.dll 	nsScriptLoader::OnStreamComplete 	content/base/src/nsScriptLoader.cpp:1183
53 	xul.dll 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:125
54 	xul.dll 	nsHTTPCompressConv::OnStopRequest 	netwerk/streamconv/converters/nsHTTPCompressConv.cpp:127
55 	xul.dll 	nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:4253
56 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:578
57 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
58 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
59 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
60 	xul.dll 	nsThread::GetObserver 	xpcom/threads/nsThread.cpp:705
61 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:494
62 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
63 	xul.dll 	nsProxyObjectCallInfo::Run 	xpcom/proxy/src/nsProxyEvent.cpp:182
64 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
65 	nspr4.dll 	_MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
66 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
67 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
68 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
69 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
70 	xul.dll 	xul.dll@0xbc03bf 	
71 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
72 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3557
73 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
74 	firefox.exe 	firefox.exe@0x4033 	
75 	firefox.exe 	__tmainCRTStartup 	crtexe.c:594
76 	firefox.exe 	_SEH_epilog4 	
77 	kernel32.dll 	BaseProcessStart 	
78 	kernel32.dll 	GetCodePageFileInfo 	
79 	kernel32.dll 	BaseProcessStart 	
80 	firefox.exe 	pre_c_init 	crtexe.c:304

Show/hide other threads
(Reporter)

Comment 1

6 years ago
Alas, once again the meta bug did not show.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595351
You need to log in before you can comment on or make changes to this bug.