Last Comment Bug 707054 - browser_bug703210.js does not remove event listener
: browser_bug703210.js does not remove event listener
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Cameron McCormack (:heycam)
:
Mentors:
Depends on:
Blocks: 703176
  Show dependency treegraph
 
Reported: 2011-12-01 18:39 PST by Cameron McCormack (:heycam)
Modified: 2012-02-01 14:00 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove event listener added in browser_bug703210.js. (1.15 KB, patch)
2011-12-01 18:39 PST, Cameron McCormack (:heycam)
masayuki: review+
Details | Diff | Review

Description Cameron McCormack (:heycam) 2011-12-01 18:39:03 PST
This causes problems for later tests that have popups.
Comment 1 Cameron McCormack (:heycam) 2011-12-01 18:39:52 PST
Created attachment 578473 [details] [diff] [review]
Remove event listener added in browser_bug703210.js.
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-12-01 18:46:56 PST
Comment on attachment 578473 [details] [diff] [review]
Remove event listener added in browser_bug703210.js.

Wow, thank you.

Could you replace all |onPopupShowing| with |onPopupShown| before landing?
Comment 3 Cameron McCormack (:heycam) 2011-12-01 18:48:19 PST
Sure thing, thanks for the quick review. :)
Comment 4 Cameron McCormack (:heycam) 2011-12-02 04:29:20 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/99860d7fd6ac
Comment 5 Ed Morley [:emorley] 2011-12-02 12:05:31 PST
https://hg.mozilla.org/mozilla-central/rev/99860d7fd6ac

Note You need to log in before you can comment on or make changes to this bug.