Last Comment Bug 707085 - "ASSERTION: Battery API: When charging and level at 1.0, remaining time should be 0. Please fix your backend!"
: "ASSERTION: Battery API: When charging and level at 1.0, remaining time shoul...
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Mounir Lamouri (:mounir)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 710178
Blocks: 326633 705084
  Show dependency treegraph
 
Reported: 2011-12-01 23:30 PST by Jesse Ruderman
Modified: 2012-02-01 14:00 PST (History)
3 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (43 bytes, text/html)
2011-12-01 23:30 PST, Jesse Ruderman
no flags Details
Patch v1 (1.29 KB, patch)
2011-12-02 05:37 PST, Mounir Lamouri (:mounir)
jonas: review+
mounir: checkin+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-12-01 23:30:11 PST
Created attachment 578510 [details]
testcase

Calling navigator.mozBattery triggers:

###!!! ASSERTION: Battery API: When charging and level at 1.0, remaining time should be 0. Please fix your backend!: 'Error', file dom/battery/BatteryManager.cpp, line 200

My MacBook Pro is fully charged and plugged in.  I am running Mac OS X 10.6.
Comment 1 Mounir Lamouri (:mounir) 2011-12-02 05:37:06 PST
Created attachment 578558 [details] [diff] [review]
Patch v1

Oups, I forgot two changes. I guess it was a good idea to put that assertion :)
Comment 2 Mounir Lamouri (:mounir) 2011-12-02 05:38:00 PST
This should actually apply on all platforms without battery backends (Windows, Mac and Linux without DBus).
Comment 3 Mounir Lamouri (:mounir) 2011-12-02 05:39:00 PST
Comment on attachment 578558 [details] [diff] [review]
Patch v1

Jonas, feel free to take this review from Chris. It's a two-line change (for real this time ;)) and Chris is on vacation AFAIK.
Comment 4 Mounir Lamouri (:mounir) 2011-12-04 05:02:43 PST
I marked this in-testsuite+ because technically the mochitests were throwing an assert but we don't fail on them yet.
Comment 5 Ed Morley [:emorley] 2011-12-04 07:18:53 PST
https://hg.mozilla.org/mozilla-central/rev/3d2eac7dcf66

Note You need to log in before you can comment on or make changes to this bug.