Last Comment Bug 707121 - msvc* dlls will never get removed on update
: msvc* dlls will never get removed on update
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on:
Blocks: 696422
  Show dependency treegraph
 
Reported: 2011-12-02 03:31 PST by Mark Banner (:standard8)
Modified: 2012-02-16 09:27 PST (History)
1 user (show)
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
The fix (1.11 KB, patch)
2011-12-02 03:31 PST, Mark Banner (:standard8)
khuey: review+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2011-12-02 03:31:49 PST
Created attachment 578538 [details] [diff] [review]
The fix

When we change the version of MSVC that we're using, we'll start shipping some new dlls, however we won't actually remove the old ones. This is because in removed-files.in they are listed as:

@BINPATH@/msvcm80.dll
@BINPATH@/msvcp80.dll
(etc)

However, the golden rule for moving/copying things from package-manifest.in is that you remove @BINPATH@.

Currently we're trying to remove bin/msvc* rather than just msvc* (I verified this looking at the make partial mar step in a nightly builds).
Comment 1 Mark Banner (:standard8) 2011-12-02 06:21:49 PST
Landed on inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/0a8ff3d835ba
Comment 2 Ed Morley [:emorley] 2011-12-02 12:04:13 PST
https://hg.mozilla.org/mozilla-central/rev/0a8ff3d835ba

Note You need to log in before you can comment on or make changes to this bug.