Upgrade message on PPC Mac: Redirect to a page explaining that Firefox >4 not available

RESOLVED DUPLICATE of bug 766606

Status

RESOLVED DUPLICATE of bug 766606
7 years ago
6 years ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 578621 [details]
screenshot

I've got an old Mac Mini with OS X 10.5.8 on it. I open up Firefox, aargh its 3.6. The home page says "Urgent you are out of date, upgrade" so I click on the next link and I get his page that says. Get the free update....

But in hard to read grey text it says "Unfortunately the latest version of Firefox isn't... " etc. As per screenshot.

I click through the read more (which is a little hard to spot) and I think I should be ok.

User agent:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

Comment 1

7 years ago
Andy, thanks for flagging.

Chrissie, can you investigate? Looks like we've got a missing button.
Assignee: nobody → cbrodigan
(In reply to John Slater from comment #1)
> Andy, thanks for flagging.
> 
> Chrissie, can you investigate? Looks like we've got a missing button.


Firefox versions 4 and up are not supported on PPC Macs

Comment 3

7 years ago
(In reply to raymond [:retornam] from comment #2)
> (In reply to John Slater from comment #1)
> > Andy, thanks for flagging.
> > 
> > Chrissie, can you investigate? Looks like we've got a missing button.
> 
> 
> Firefox versions 4 and up are not supported on PPC Macs

Raymond, any ideas on a solution to fill this gap?
(In reply to mcbmoz from comment #3)
> (In reply to raymond [:retornam] from comment #2)
> > (In reply to John Slater from comment #1)
> > > Andy, thanks for flagging.
> > > 
> > > Chrissie, can you investigate? Looks like we've got a missing button.
> > 
> > 
> > Firefox versions 4 and up are not supported on PPC Macs
> 
> Raymond, any ideas on a solution to fill this gap?

Maybe, we can  redirect to a page which explains the reason why they cannot upgrade.
(In reply to raymond [:retornam] from comment #4)
> Maybe, we can  redirect to a page which explains the reason why they cannot
> upgrade.

Probably, yes. We'd need to:
1. Detect PPC Macs by user agent on appropriate pages
2. Create a new page explaining the PPC issue (Maybe on SUMO?)
3. Redirect to, or link to, this page for PPC browsers.

Updated

7 years ago
Summary: Not sure how to install Firefox → Upgrade message on PPC Mac: Redirect to a page explaining that Firefox >4 not available

Updated

7 years ago
Assignee: christine.brodigan → chrismore.bugzilla
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
How about we have a message that directs them here?

http://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-10-4-or-powerpc#w_powerpc-processors

This is what we are doing for the upgrade message on the new start.mozilla.org page for 3.6 & < users.

Updated

7 years ago
Assignee: chrismore.bugzilla → nobody
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766606
You need to log in before you can comment on or make changes to this bug.