The default bug view has changed. See this FAQ.

AzureBackend is not aligned with the other Graphics information in about:support

RESOLVED FIXED in mozilla12

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: JK, Assigned: KWierso)

Tracking

Trunk
mozilla12
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111122192043

Steps to reproduce:

AzureBackend is not aligned with the other Graphics information in about:support.
(Reporter)

Comment 1

5 years ago
Created attachment 578631 [details]
screenshot
(Reporter)

Updated

5 years ago
Hardware: x86_64 → x86

Comment 2

5 years ago
It's the same in current Nightly I see...

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111202 Firefox/11.0a1 ID:20111202031055

Updated

5 years ago
Blocks: 702770
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
The cause is that the data is currently being displayed in two different tables which are set to fit to content (the default): in the first table, "graphics-tbody", the header column fits to its longest string, "GPU Accelerated Windows"; in the second table, "graphics-info-properties" is fitting to "AzureBackend".

I'd suggest using a unique table for all graphics information, using two separate "tbody" elements(instead of two different "table" elements) for separating content, keeping the same identifiers for compatibility. Another possible workaround could be setting a percent width, but honestly I don't like that approach (will behave worse in viewport resize and may trigger unexpected issues due to internationalization etc.
(Assignee)

Comment 4

5 years ago
Created attachment 591667 [details] [diff] [review]
Move tbodys into single table

This patch seems to work on my local build.

Asking for review from Jeff since he reviewed the patch in bug 702770 that added the table in the first place. Please redirect the request if I'm doing this wrong. :)
Attachment #591667 - Flags: review?(jmuizelaar)
(Assignee)

Updated

5 years ago
Assignee: nobody → kwierso
(Assignee)

Comment 5

5 years ago
Created attachment 591668 [details]
screenshot with fix

This also gets rid of the not-good-looking double border around the AzureBackend row.
Comment on attachment 591667 [details] [diff] [review]
Move tbodys into single table

Looks fine to me.
Attachment #591667 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 7

5 years ago
Created attachment 591876 [details] [diff] [review]
Version someone can check in for me.

Here's a version that has all of the commit info that someone can use to check this in for me, since I don't have commit access. Carrying forward r+.
Attachment #591667 - Attachment is obsolete: true
Attachment #591876 - Flags: review+
(Assignee)

Updated

5 years ago
Whiteboard: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b55af240c15
Whiteboard: checkin-needed
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/7b55af240c15
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 10

5 years ago
still NOT aligned here (FF11, Vista sp2).
why?
thanks.

Comment 11

5 years ago
why you say Fixed? very odd...
Target milestone = Mozilla12

Comment 13

5 years ago
sorry sorry 
and thank you for your reply ;)
No problem :-)
You need to log in before you can comment on or make changes to this bug.