Last Comment Bug 707223 - AzureBackend is not aligned with the other Graphics information in about:support
: AzureBackend is not aligned with the other Graphics information in about:support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Wes Kocher (:KWierso)
:
Mentors:
Depends on:
Blocks: 702770
  Show dependency treegraph
 
Reported: 2011-12-02 10:33 PST by JK
Modified: 2012-03-13 15:16 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (19.92 KB, image/png)
2011-12-02 10:34 PST, JK
no flags Details
Move tbodys into single table (524 bytes, patch)
2012-01-25 17:45 PST, Wes Kocher (:KWierso)
jmuizelaar: review+
Details | Diff | Splinter Review
screenshot with fix (31.94 KB, image/png)
2012-01-25 17:47 PST, Wes Kocher (:KWierso)
no flags Details
Version someone can check in for me. (927 bytes, patch)
2012-01-26 11:39 PST, Wes Kocher (:KWierso)
wkocher: review+
Details | Diff | Splinter Review

Description JK 2011-12-02 10:33:41 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111122192043

Steps to reproduce:

AzureBackend is not aligned with the other Graphics information in about:support.
Comment 1 JK 2011-12-02 10:34:35 PST
Created attachment 578631 [details]
screenshot
Comment 2 Antti Tervasmäki 2011-12-02 11:13:48 PST
It's the same in current Nightly I see...

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111202 Firefox/11.0a1 ID:20111202031055
Comment 3 Helder "Lthere" Magalhães 2011-12-21 06:22:24 PST
The cause is that the data is currently being displayed in two different tables which are set to fit to content (the default): in the first table, "graphics-tbody", the header column fits to its longest string, "GPU Accelerated Windows"; in the second table, "graphics-info-properties" is fitting to "AzureBackend".

I'd suggest using a unique table for all graphics information, using two separate "tbody" elements(instead of two different "table" elements) for separating content, keeping the same identifiers for compatibility. Another possible workaround could be setting a percent width, but honestly I don't like that approach (will behave worse in viewport resize and may trigger unexpected issues due to internationalization etc.
Comment 4 Wes Kocher (:KWierso) 2012-01-25 17:45:12 PST
Created attachment 591667 [details] [diff] [review]
Move tbodys into single table

This patch seems to work on my local build.

Asking for review from Jeff since he reviewed the patch in bug 702770 that added the table in the first place. Please redirect the request if I'm doing this wrong. :)
Comment 5 Wes Kocher (:KWierso) 2012-01-25 17:47:00 PST
Created attachment 591668 [details]
screenshot with fix

This also gets rid of the not-good-looking double border around the AzureBackend row.
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-01-25 19:14:29 PST
Comment on attachment 591667 [details] [diff] [review]
Move tbodys into single table

Looks fine to me.
Comment 7 Wes Kocher (:KWierso) 2012-01-26 11:39:34 PST
Created attachment 591876 [details] [diff] [review]
Version someone can check in for me.

Here's a version that has all of the commit info that someone can use to check this in for me, since I don't have commit access. Carrying forward r+.
Comment 8 Phil Ringnalda (:philor, back in August) 2012-01-29 17:17:03 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b55af240c15
Comment 9 Marco Bonardo [::mak] 2012-01-30 02:52:30 PST
https://hg.mozilla.org/mozilla-central/rev/7b55af240c15
Comment 10 banakon 2012-03-13 15:09:58 PDT
still NOT aligned here (FF11, Vista sp2).
why?
thanks.
Comment 11 banakon 2012-03-13 15:12:20 PDT
why you say Fixed? very odd...
Comment 12 Ed Morley [:emorley] 2012-03-13 15:13:04 PDT
Target milestone = Mozilla12
Comment 13 banakon 2012-03-13 15:15:25 PDT
sorry sorry 
and thank you for your reply ;)
Comment 14 Ed Morley [:emorley] 2012-03-13 15:16:37 PDT
No problem :-)

Note You need to log in before you can comment on or make changes to this bug.