Update AndroidManifest.xml.in minSdkVersion from 5 (Eclair 2.0) to 7 (Eclair MR1 2.1)

RESOLVED DUPLICATE of bug 662891

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 662891
6 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Fennec's AndroidManifest.xml.in currently specifies minSdkVersion 5 (Eclair), but QA says our minimum tested version is 8 (Froyo):

    <uses-sdk android:minSdkVersion="5" android:targetSdkVersion="11"/>

We might also want to increase targetSdkVersion from 11 (Honeycomb) to the latest version 14 (ICS).
We have very few devices in house that are 2.1. The ones we do have start up crashes. bug 701791 and bug 699301 

According to the last Android market stats 3-4% of our users are on Android 2.1. Is it possible from the Market interface to see what the breakdown of what devices are running Android 2.1? If it makes sense we can acquire some of these devices. 

Removing a supported OS is a project wide decision.
(Reporter)

Comment 2

6 years ago
Fennec is currently built for minSdkVersion Android 2.0 and up. Do we have Fennec users on 2.0 or 2.0.1 (the early versions of Eclair before 2.1)?

Do we have Android 2.0 and 2.0.1 devices to test?
(Reporter)

Comment 3

6 years ago
btw, the Mozilla wiki says Fennec requires Android 2.1 or later:

https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements

If 2.1 is the correct minimum version, then Fennec's mindSdkVersion should be updated from 5 (Eclair 2.0) to 7 (Eclair MR1 2.1).
(Reporter)

Updated

6 years ago
Summary: Update AndroidManifest.xml.in minSdkVersion from 5 (Eclair) to 8 (Froyo) → Update AndroidManifest.xml.in minSdkVersion from 5 (Eclair 2.0) to 7 (Eclair MR1 2.1)
There's very little difference between Android 2.0 and 2.1.  The only reason some of our marketing material lists the minimum version as 2.1 instead of 2.0 is just that Android 2.0 has been phased out of the market and has basically zero installed base.  For discussion, see:
https://groups.google.com/d/msg/mozilla.dev.planning/uNeZsvYN-7c/te0NfCWomNMJ

I don't see any good reason to change the minimum version from 5 to 7, because I'm not aware of any of our code that would be improved by such a change.  Instead we should probable go straight to minSdkVersion=8 as soon as enough of our users have upgraded from 2.1 to 2.2 or later.  This would let us remove some Eclair-only code paths.  We already have bug 662891 open for this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662891
You need to log in before you can comment on or make changes to this bug.