Last Comment Bug 707578 - Package.pm shouldn't copy older files
: Package.pm shouldn't copy older files
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Mounir Lamouri (:mounir)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 707569
  Show dependency treegraph
 
Reported: 2011-12-04 15:35 PST by Mounir Lamouri (:mounir)
Modified: 2012-04-30 08:10 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.40 KB, patch)
2011-12-04 15:35 PST, Mounir Lamouri (:mounir)
robert.strong.bugs: review+
khuey: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-12-04 15:35:37 PST
Created attachment 578947 [details] [diff] [review]
Patch v1

Packager.pm is currently copying all files regardless of the last modification time. It's currently not changing anything because destination files are removed before copying. However, with bug 707569, we might end up not removing those files (maybe only if a certain env variable is set).
Comment 1 Mounir Lamouri (:mounir) 2011-12-11 05:55:32 PST
By any chance Kyle, do you think you could take this review?
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2011-12-14 14:38:23 PST
Comment on attachment 578947 [details] [diff] [review]
Patch v1

Though this code is under installer it is actually packaging code and should be reviewed by Kyle or Ted. I'm ok with the patch but it would be best to have Kyle review it.

Note You need to log in before you can comment on or make changes to this bug.