Saving images via drag and drop on Dribbble creates gzipped PNG files

RESOLVED DUPLICATE of bug 510670

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 510670
6 years ago
6 years ago

People

(Reporter: Max, @maxart, Unassigned)

Tracking

10 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111204 Firefox/10.0a2
Build ID: 20111204042031

Steps to reproduce:

Drag and drop an image from a webpage to the Finder in order to save it.
Video of the issue: http://cl.ly/3R0Y0o3Z0q0Q2c2f3F0j (showing Chrome's behavior first, then Firefox/Aurora's)


Actual results:

The image was added to Finder, but trying to open it reveals the error: "The file xxx could not be opened. It may be damaged or use a file forma that Preview doesn't recognize"


Expected results:

The image should have been saved properly and should be working.
(Reporter)

Comment 1

6 years ago
Example URL: http://dribbble.com/shots/86932-Code-editor
How are you taking those screenshots? Other file types and other pngs work fine for me. The only files that I can reproduce this with are the png screenshots you've uploaded to that site.
(Reporter)

Comment 3

6 years ago
@Dietrich it happens for all the screenshots on Dribbble - not just mines.
Could it be because the <img /> on Dribbble have their src as "...xxx.png?1323062013" ?
(Reporter)

Updated

6 years ago
Summary: Saving images via drag and drop isn't working → Saving images via drag and drop isn't working on Dribbble

Comment 4

6 years ago
right-click -> view image. Then drag and drop. Does this work?
If not, can you add the URL of a non-working image here?
(Reporter)

Comment 5

6 years ago
@Paul Right-click -> View image, then drag and drop to Desktop/Finder has the exact same effect: the image can't be opened (same error as on my video when trying to open the image: http://cl.ly/3R0Y0o3Z0q0Q2c2f3F0j ). It appears to happen with every images on Dribbble.

Here are two example URLS:
- http://dribbble.com/system/users/25514/screenshots/341834/projectmanagement.png?1323102838

- http://dribbble.com/system/users/1784/screenshots/341492/d251.jpg?1323073125

Comment 6

6 years ago
And if you remove "?1323073125", does it work?
(Reporter)

Comment 7

6 years ago
@Paul nope. Same thing, still doesn't work.

Comment 8

6 years ago
What is the size of the generated file? Is it empty? Can you try with a nightly build (http://firefox.com/nightly)?
(Reporter)

Comment 9

6 years ago
@Paul for this image http://dribbble.com/system/users/25514/screenshots/341834/projectmanagement.png , the size is 195 KB when "saved" (which is the correct size of the image - it's 195 KB as well when saving it with Chrome, and the image works).

I will download and install the latest Nightly now, and report back again.
(Reporter)

Comment 10

6 years ago
@Paul just tested in Nightly (11.0a1 (2011-12-05)), exact same issue (for both drag and drop for the Dribbble page, and after View image). :(

Comment 11

6 years ago
Can you please attach the generated file from Firefox and Chrome?
(Reporter)

Comment 12

6 years ago
Created attachment 579270 [details]
Broken image generated from Firefox
(Reporter)

Comment 13

6 years ago
Created attachment 579271 [details]
Working image generated by Chrome

Comment 14

6 years ago
Interesting, Firefox creates a gzip file:

> $ file firefox.png chrome.png
> firefox.png: gzip compressed data, from Unix
> chrome.png:  PNG image data, 400 x 300, 8-bit/color RGB, non-interlaced
> $ mv firefox.png firefox.png.gz
> $ gunzip firefox.png.gz
> $ md5sum firefox.png chrome.png
> 7b6127c8d8ecf6ab07692247f3643ffe  firefox.png
> 7b6127c8d8ecf6ab07692247f3643ffe  chrome.png

Updated

6 years ago
Summary: Saving images via drag and drop isn't working on Dribbble → Saving images via drag and drop on Dribbble creates gzipped PNG files
(Reporter)

Comment 15

6 years ago
Hmmm, odd indeed :/
So is that a confirmed Firefox bug, or something to do with Dribbble itself (although it works fine on other browsers)?

Comment 16

6 years ago
Just tested on a Mac. I can reproduce this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looks like a duplicate of bug 510670. Thanks for reporting it Max!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510670
You need to log in before you can comment on or make changes to this bug.