Last Comment Bug 707643 - 100% CPU usage and unresponsive script dialog pops up during page loading - www.eurogamer.net
: 100% CPU usage and unresponsive script dialog pops up during page loading - w...
Status: RESOLVED DUPLICATE of bug 710780
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 11 Branch
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
http://www.eurogamer.net/articles/dig...
Depends on:
Blocks: 693754
  Show dependency treegraph
 
Reported: 2011-12-05 05:02 PST by Alice0775 White
Modified: 2012-02-13 13:05 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments

Description Alice0775 White 2011-12-05 05:02:47 PST
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/c2102c45c8da
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111204 Firefox/11.0a1 ID:20111204031102

100% CPU usage and unresponsive script dialog pops up during page loading - www.eurogamer.net .

See forum( http://forums.mozillazine.org/viewtopic.php?p=11530307#p11530307 )

Reproducible: Always

Steps to Reproduce:
1 Start Firefox with clean profile
2 Open URL

Actual Results:
  100% CPU usage
  "Unresponsive script dialog" pops up

Expected Results:
  The page is displayed without "unresponsive script dialog"

Regression window(cahed m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/a68c96c1d8e0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111203 Firefox/11.0a1 ID:20111203031117
Fails:
http://hg.mozilla.org/mozilla-central/rev/13afcd4c097c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111203 Firefox/11.0a1 ID:20111203122618
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a68c96c1d8e0&tochange=13afcd4c097c

Regression window(jm nightly)
Works:
http://hg.mozilla.org/projects/jaegermonkey/rev/498d6fa378ba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111020 Firefox/10.0a1 ID:20111020073958
http://hg.mozilla.org/projects/jaegermonkey/rev/1d1656b60947
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111021 Firefox/10.0a1 ID:20111021040331
Fails:
http://hg.mozilla.org/projects/jaegermonkey/rev/d849045ad3f2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111022 Firefox/10.0a1 ID:20111022040331
Pushlog:
http://hg.mozilla.org/projects/jaegermonkey/pushloghtml?fromchange=1d1656b60947&tochange=d849045ad3f2
Comment 1 Alice0775 White 2011-12-05 05:22:36 PST
"Unresponsive script dialog" is as follows:

>A script on this page may be busy, or it may have stopped responding.
>You can stop the script now, or you can continue to see if the script will complete.
>
>Script: http://www.eurogamer.net/scripts/Eurogamer/jwplayer/jwplayer.js?v11.0.5.2:1
Comment 2 David Mandelin [:dmandelin] 2011-12-13 18:52:09 PST
I don't actually get the unresponsive script dialog, but I can tell the browser is unresponsive for a longer period of time than previous versions. 

According to Shark, about 60% of the time is in fun_getProperty. Brian, does that ring a bell wrt to removing getFunctionPrivate?
Comment 3 Brian Hackett (:bhackett) 2011-12-15 11:42:47 PST
This may be related to bug 710780 (logic bug in fun_getProperty).
Comment 4 David Mandelin [:dmandelin] 2011-12-20 18:01:38 PST
Alice, can you retest this now that bug 710780 is fixed? I'm not sure I can reproduce it locally, so it's hard for me to tell if it was fixed.
Comment 5 Alice0775 White 2011-12-20 18:32:59 PST
(In reply to David Mandelin from comment #4)
> Alice, can you retest this now that bug 710780 is fixed? I'm not sure I can
> reproduce it locally, so it's hard for me to tell if it was fixed.

I cannot reproduce problems of Bug 707643 and bug 710780 anymore.

So, I mark this as duplicate.

http://hg.mozilla.org/mozilla-central/rev/2afd7ae68e8b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111220 Firefox/11.0a1 ID:20111220031159

*** This bug has been marked as a duplicate of bug 710780 ***

Note You need to log in before you can comment on or make changes to this bug.